0

I don't understand why when I add a membership and I check "Send Confirmation and Receipt" I don't receive the receipt.

enter image description here

On the other hand, if I use "Send Receipt" from the action menu of the contribution, it works (the receipt is sent).

enter image description here

I'm using CiviCRM 5.67.0 on WorpPres (I don't tried with previous versions)

4
  • Hi Masetto. My guess is that something is amiss with your Message Templates, and as you can see here dmaster.demo.civicrm.org/civicrm/admin/… there are different ones for Contribution v Membership, and for On-line and Off-line. And that your Off-line Membership one isn't firing. If you have never modified these then this is unlikely to be the problem, but is first thing I would check.
    – petednz - fuzion
    Nov 9, 2023 at 21:18
  • Hi @petednz-fuzion, I don't have modified these templates. The "Send receipt" action in contribution joined to a membership uses the "Memberships - Receipt (on-line)" template. I tried with 2 different installations of CiviCRM 5.67.0 and I have the same problem. In another installation, but version 5.66.2 on Drupal, this works. The odd thing is that the "Receipt Sent" of the contribution is filled, but the email was not sent.
    – masetto
    Nov 10, 2023 at 7:25
  • and have you checked the server mail logs (or however you are sending)?
    – petednz - fuzion
    Nov 10, 2023 at 17:44
  • of course. In fact, when I "Send Receipt" from the action menu of the contribution, it works (the receipt is sent).
    – masetto
    Nov 22, 2023 at 17:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.