I've recently upgraded a couple of sites and the Quick Search has stopped working on both of them. I try typing a name and it just spins. I've tried changing the options in Search Preferences but it doesn't make a difference. I get the same results for the other options, such as Contact ID.

Site A... Drupal 9.5.11, CiviCRM 5.67.0

Site B... Drupal 10.1.16, CiviCRM 5.66.2

In the console, I'm getting messages like:

Uncaught TypeError: result.values is undefined
    source https://mysite.org.uk/web/libraries/civicrm/core/js/crm.menubar.js?r=OzNRAen_GB:297
    jQuery 6
    api3 https://mysite.org.uk/web/libraries/civicrm/core/js/crm.ajax.js?r=OzNRAen_GB:120
    source https://mysite.org.uk/web/libraries/civicrm/core/js/crm.menubar.js?r=OzNRAen_GB:295

Any suggestions that I can try?

  • 1
    There were a couple quicksearch issues fixed recently. Also try composer civicrm:publish since if the js changes didn't get copied into web you might see issues.
    – Demerit
    Nov 13, 2023 at 18:23

1 Answer 1


Just to confirm, I have run civicrm:publish, and then cleared the cached data in the browser and it's now working for both sites.

I had tried an alternative browser before, in case it was cached info causing the issue, and on the second site I fixed just now I checked whether I definitely needed to clear the cache after running that command and the answer was yes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.