1

I have created a form in Form builder to enable a logged in user to update some details we have stored for them (their Gift Aid status). This displays via a short code in a wordpress page ([civicrm component="afform" name="afformGiftAid" hijack="0"])

If I am logged in as an administrator it updated the record. If I am logged in as a "general user" it does not update the record. I am guessing this is a permission issue - Can anyone advise what permissions need to used in Civi/ Wordpress to ensure the record gets updated - I have tried a few and no success.

We are getting the following errors in the Log files

[debug] Silently ignoring exception in Afform processGenericEntity call: Authorization failed [debug] $API Request Authorization failed = #0 /.../wp-content/plugins/civicrm/civicrm/Civi/API/Kernel.php(153): CRM_Core_Error::backtrace("API Request Authorization failed", TRUE)

Wordpress 6.4.1 CivCRM 5.65.2

1 Answer 1

3

I was experiencing a similar issue, the difference for me is I have a public facing form that allows non-logged in users to submit the form to create individuals in Civi. Located on the Form Settings tab, I had the Form's Permission set to Generic: Allow all users (including anonymous) but experienced the same Authorization Failed error.

My solution was to change each of the form's "entities" Security from User-Based to Form-Based which then used the Form's Permissions mentioned above. To find this setting:

  1. Edit your form and find the Form Settings tab (should be selected by default).
  2. Each of the tabs to the right is what I'm calling an "entity". You may only have one or many depending on your form.
  3. On each of these tabs, about half way down, directly under the Options header is the Security drop down. This is what I changed to Form-Based.

I hope this helps you.

1
  • Thanks for that - Have parked it for now, but will take alook at that option when I get a moment! Jan 16 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.