0

For PHP version reason, I move Joomla! & CiviCRM from example.org/civicrm to civicrm.example.org. I changed all civicrm.settings.php in admin and frontend folders and I emptied the cache, template_c and log folder and CIVICRM_SITE_KEY is always the same. Everything works fine and cron URL could be fetch (blank screen on the web but Status: 200 after crontab run) So, no mailing is sent automatically. But I can send it when I run the task manually ?!

On CiviCRM status, I can read that no cron is running. But at tihs time, I really don't know where to find to resolve this issue.

I tried both https://example.org/administrator/components/com_civicrm/civicrm/bin/cron.php?name=&pass=&key= and the command wget -O - -q -t 1 'https://example.org/administrator/components/com_civicrm/civicrm/bin/cron.php?name=&pass=&key=', results are OK but CiviCRM doesn't recognize those execution.

I also tried to change PHP version (7.4, 8.0 and 8.1), without any change. I only have a warning about session when I display PHP errors.

On this thread For some reason, cron doesn't work. On CMS joomla, I note that the cron user must be a super-admin, but I tested and it only work once : now, there is an error status with cron in CiviCRM.

1 Answer 1

0

Can you use the cv method? That works well.

1
  • No, I don't think so. I don't find it on Joomla! and I don't find how to write the cron task. And now with J!4, the usual cron task doesn't work anymore.
    – Alain Rihs
    Commented Nov 21, 2023 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.