0

This works:

  • I have Civi set up to send email through my personal Google account (using an App Password because I use 2FA). This works, but the emails have my address as sender, of course, which we want to fix.

This does not work:

  • My organisation also uses Google, and my account also uses 2FA, and I have also created an App Password - just as with my personal account.
  • In CiviCRM, in the SMTP settings, I only replace the SMTP username and SMTP password, switching from my personal data to the organisation data.
  • Sending a test email causes CiviCRM to report "OK", but that test email never arrives.
  • Switching back to my personal account data and sending a new test email is successful: CiviCRM gives the same confirmation and that email arrives.
  • Despite everything seeming identical, what am I missing?

2 Answers 2

1

I found that I needed to set up a new user account in our Google organisation and use that in CiviCRM. Now it works. Here are the steps I did:

Note: English settings might be named a little different than given here; our CiviCRM is set to German so I translate onthe fly.

  1. create new user account in our Google organisation.
  2. Gmail settings > Forwarding and POP/IMAP > turn on POP access. (Mark Gmail's copy as read.)
  3. Google account settings > security > turn on "less secure app access".
  4. CiviCRM > Admin > CiviMail > Sender address > enter email address of Gmail account.
  5. CiviCRM > Admin > CiviMail > Mail accounts > edit default account:
    1. name = Gmail
    2. server = pop.gmail.com
    3. username = email address of Gmail account
    4. password = password of Gmail account (just the regular password, not some app-specific one, because we chose to use "less secure app access".)
    5. local part = leave empty
    6. email domain = the part after @ in the email address of Gmail account
    7. return path = leave empty
    8. protocol = POP3
    9. mail folder = leave empty
    10. use SSL = turn checkbox on
    11. use for = bounce

With these settings, the button "save and send test mail" resulted in a successful alert in CiviCRM, and the email was indeed sent to the test recipient.

0

You may want to check email permissions in your organization Google Workspace for the email account you switch to and see the "From Email Address Options" CiviCRM page ("Administer > Communications > FROM Email Addresses")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.