2

I've found several posts about this error but so far none have helped.

I have a Joomla system where I am using a CiviCRM profile for user registration. It has been working fine for several months.

However in the last week I've noticed CiviCRM contacts are no longer being created when the user submits the registration form. Joomla users are created just fine, and notification emails including information from the Civi profile are sent correctly. But no contact is created, and the log file shows

"The requested Profile (gid=16) is disabled OR it is not configured to be used for 'Profile' listings in its Settings OR there is no Profile with that ID OR you do not have permission to access this profile. Please contact the site administrator if you need assistance."

Since this was working before, I'm not sure what's changed to cause the problem. Based on other posts, I have checked the following:

  • Profile is enabled
  • Profile is set to be used for user registration
  • All custom data fields used in the profile are set to "User/User Admin only"
  • Joomla public and guest groups have permissions "Civi:Create profile, Civi:edit profile, Civi:view profile, Civi:access custom data"

Stack trace seems clear it is permissions issue:

/home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Core/BAO/UFGroup.php:196 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Profile/Form.php:408 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Profile/Form/Search.php:32 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Core/Form.php:707 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Core/QuickForm/Action/Display.php:76 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/packages/HTML/QuickForm/Controller.php:203 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/packages/HTML/QuickForm/Page.php:103 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Core/Controller.php:355 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Profile/Page/Listings.php:387 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Profile/Page/Router.php:107 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php:319 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php:69 { …}
      /home/XXXXXXXX/siteroot/administrator/components/com_civicrm/civicrm/CRM/Core/Invoke.php:36 { …}
      /home/XXXXXXXX/siteroot/components/com_civicrm/civicrm.php:84 { …}
      /home/XXXXXXXX/siteroot/components/com_civicrm/civicrm.php:11 { …}
      /home/XXXXXXXX/siteroot/libraries/src/Component/ComponentHelper.php:402 { …}
      /home/XXXXXXXX/siteroot/libraries/src/Component/ComponentHelper.php:377 { …}
      /home/XXXXXXXX/siteroot/libraries/src/Application/SiteApplication.php:194 { …}
      /home/XXXXXXXX/siteroot/libraries/src/Application/SiteApplication.php:233 { …}
      /home/XXXXXXXX/siteroot/libraries/src/Application/CMSApplication.php:225 { …}
      /home/XXXXXXXX/siteroot/index.php:49 { …}

What else can I check? Thanks!

Joomla 3.10.11 (I know, upgrade is in progress!) CiviCRM 5.63.2

2
  • Does the stand-alone Profile (/civicrm/profile/create/?gid=16&reset=1) create CiviCRM records? Any recent software changes prior to the error jumps out? Any oddities in civicrm logs and/or apache/php error logs related to the case?
    – yurg
    Nov 28, 2023 at 12:12
  • The stand-alone profile behaves the same way as the front-facing profile page -- Joomla user is created, but after adding profile listing permissions as per pradeep, now not even the error message in the Civi or PHP logs.
    – minbori
    Nov 28, 2023 at 16:30

1 Answer 1

2

The error only appears if

  1. Profile id:16 do not exists.

  2. No fields in the profile id:16

  3. user role do not have 'CiviCRM: profile listings' permission

  4. If ACL is enabled for the profiles, it needed to added to view in list mode

HTH

Pradeep

6
  • 1. Profile definitely exists.
    – minbori
    Nov 28, 2023 at 15:18
  • thn may be #3 or #4 Nov 28, 2023 at 15:40
  • 1 and 2 both exist. I gave the Public user role CiviCRM:profile listings AND CiviCRM:Profile listings and forms, even though the documentation says "only give these permissions to roles you trust" (I'm not sure what the difference is between these two permissions). Still not working, but now no errors in civi logs.
    – minbori
    Nov 28, 2023 at 16:20
  • Is #4 CiviCRM ACL? I don't use any Civi ACL.
    – minbori
    Nov 28, 2023 at 16:22
  • What is the URL of the profile, exclude the domain name Nov 29, 2023 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.