1

I am running CIVICRM on WordPress 6.4.1 with PHP 7.4. Upgraded both platforms to the latest versions. After changing php version from 7.4 to 8.1, I get a WP critical error. After enabling WP debug, I get the following message.

Any idea on how to correct this?

Deprecated: auto_detect_line_endings is deprecated in ..../wp-content/uploads/civicrm/civicrm.settings.php on line 596

Fatal error: Array and string offset access syntax with curly braces is no longer supported in ..../wp-content/uploads/civicrm/ext/com.pogstone.fancytokens/fancytokens.civix.php on line 149 There has been a critical error on this website. Please check your site admin email inbox for instructions.

1
  • Beautiful. It worked. Thank you so much!!! Nov 30, 2023 at 15:24

1 Answer 1

2

There hasn't been a release for fancytokens in a while but as a workaround you can just edit that fancytokens.civix.php file and change the {0} to [0] on line 149.

For the other one just remove line 596 from your civicrm.settings.php. There was a pre-upgrade notice in 5.62 about it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.