We upgrade recently from 4.5.8 to 4.6.6 on our CiviCRM instances.

After that we note that some smart groups become empty. An example as proof:

Smart group has been emptied:

Event type = Centre Obert ...and...

Start Date - greater than or equal to "september 12th, 2013 12:00 AM" ...and...

End Date - less than or equal to "juny 20th, 2014 11:59 PM" ...and...

Participant Status ID is Inscrit ...and...

Participant Role is 1

NOTE: Cleaning caches and rebuilding smart groups has not worked.

1 Answer 1


It is not the ideal solution but so far has worked.

  1. Edit the search criteria for the affected/s smart group/s - The search result remain empty

  2. Search again - The search result will be good

  3. Update the smart group

After this the smart/s group/s works correctly again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.