1

after an upgrade of WP and Civicrm I am getting the following message:

PHP MySQL Driver (libmysqlclient) It is recommended, though not yet required, to upgrade your PHP MySQL driver (libmysqlclient) to >= 5.5.3 for utf8mb4 support.

This is a message that also apprears upon making a new installation of Civicrm.

My environment from Phpmyadmin is as follows:

Database server Server: Localhost via UNIX socket Server type: MariaDB Server connection: SSL is not being used Documentation Server version: 10.5.22-MariaDB-cll-lve - MariaDB Server Protocol version: 10 User: cpses_kee3y1i26i@localhost Server charset: UTF-8 Unicode (utf8mb4) Web server cpsrvd 11.110.0.15 Database client version: libmysql - mysqlnd 8.1.16 PHP extension: mysqli Documentation curl Documentation mbstring Documentation PHP version: 8.1.16

It looks like the utf8mb4 is already supported, so I am at a loss as to how to proceed. Can you help?

Thank you in advance.

1
  • 2
    Are you able to use the command line to run php -r "echo mysqli_get_client_info();" and post what the output is? Because it seems like you have mysqlnd from the above, but civi seems to think you have libmysqlclient.
    – Demerit
    Dec 1, 2023 at 17:14

1 Answer 1

0

All that I am getting is what looks like a version number: 3.1.22

screen grab

4
  • 1
    I guess that means you have version 3.1.22 of libmysqlclient. Ask your host if you can either switch to mysqlnd or upgrade the libmysqlclient.
    – Demerit
    Dec 4, 2023 at 13:17
  • Dear new user, please do not mess with answers (provide solution), comments (discuss post quality and information gathering) and post editing (provide more information).
    – nielo
    Dec 13, 2023 at 8:36
  • 1
    Thank you very much. I contacted the host and they applied the change you suggested and the error message disappeared.Thank you again. Dec 14, 2023 at 12:11
  • 1
    I had the same issue and followed the instructions from @Demerit and my host said, "We would like to inform you that we have enabled the nd_mysqli PHP extension and now your website loading without any issues." Worked like a charm! Dec 15, 2023 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.