0

I have a client who's organization's email is managed by an Austrian company called MyMagenta. Apparently it is related to T-Mobile. We thought that we could handle bounce processing in CiviCRM by creating an account for it in MyMagenta and using that, but apparently they don't allow external 3rd party logins via API or command line.

So I thought, OK, we'll create a gmail account for that. But Google dropped support for "less secure apps" last year. Then I though OK, I know we are using Gsuite for that with CiviCRM, I'll just create an email account for them in our GSuite account. But on the way to do that, I discovered a Google announcement that this feature would be dropped from GSuite as well by Fall of 2024.

So, I completed this and we're good for now. But come Fall of 2024, I have a half dozen CiviCRM sites that will need bounce processing email accounts that allow what Google calls "less secure apps". What do you all use?

I am religious about NOT maintaining my own mail server. Been there, done that. Too much of a time suck. I need an email service to do that. Suggestions?

1 Answer 1

1

For bounce processing/inbound you shouldn't need "less secure apps" to use google, but you do need to enable the built-in extension "oauth client", and then follow some steps at https://docs.civicrm.org/sysadmin/en/latest/setup/oauth/#enable-the-module and then where it says "adding an account via oauth" at https://docs.civicrm.org/sysadmin/en/latest/setup/civimail/#oauth

4
  • This seems pretty complicated, and I don't understand OAuth at all, although I have heard of it and know that's what's going on when I get a popup to authenticate in Thunderbird. Is there a video somewhere that shows how to do this?
    – Rob Brandt
    Dec 5, 2023 at 1:26
  • What's really throwing me in reading these directions is that in the Mail Accounts window when I click on Add Accounts, I don't get options to select the type of account (i.e. Standard, MS, or Google). I am missing something. I definitely enabled the OAuth extension.
    – Rob Brandt
    Dec 5, 2023 at 1:29
  • You probably haven't registered the connection. See also civicrm.stackexchange.com/a/38846/181
    – Demerit
    Dec 5, 2023 at 2:03
  • 1
    Thank you. This needs to be added to the CiviCRM documentation somewhere. I think it would have taken days for me to understand it and figure it out on my own.
    – Rob Brandt
    Dec 5, 2023 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.