5

Currently CiviBooking works for the LTS of 4.4.x. We are taking a look at this for 4.6.x so putting it up as a question to track progress

  • Any update on the 4.6 compatibility? We're a social profit with rooms in the making to be rented out soon. – Denis Clijsters Nov 9 '15 at 21:01
10

We are pleased to announce CiviBooking 1.5 is finally released!

This version brings compatibility with:

  • CiviCRM 4.5.x (not actively maintained)
  • CiviCRM 4.6.x
  • CiviCRM 4.7.x

It also contains a new permission structure for managing bookings.

Please feel free to get in touch if you have any question or encountered any issue. We will be actively maintaining the issue queue.

Updates:

  • CiviCRM 4.6+ compatibility
  • CiviBooking Permissions
  • Improved consistency of permission structure for managing bookings
  • Improved CiviCRM version compatibility
  • Improved menu handling
  • Fixed day view criteria
  • Fixed additional charge modal problem

The new version of the extension can be downloaded here

3

At this point there is no available release for 4.6.x and needs some funders to get a upgraded release done according to this github issue

  • Just to confirm that we are seeking funding for development for 4.5.x and 4.6.x and although we have several interested clients nothing so far has been confirmed unfortunately :( If people are able to come forward and support this we have estimated around 20h work. Best Jamie – Jamie Novick Aug 14 '15 at 10:48
3

We have civibooking running on 4.6.x - we probably haven't tried all the features but can confirm that in going through the process of setting up a Booking and setting up Resource Types and Resources we didn't hit any issues, so this is just to encourage others to get in and test thoroughly and report back so Jamie and his team get some clearer idea of what hurdles there might be, and then we can all hopefully chip in.

2

There is a branch for CiviCRM 4.5 : https://github.com/compucorp/civibooking/tree/civi4.5 that can be downloaded here.

There is no development on it since October 2014 but it seems to work on both 4.5 and 4.6. Or at least it doesn't crash. I have tested every link and made some simple booking but I don't know this extension that much so it's difficult for me to say if something is broken.

  • Thank you - we are about to spin it up on a 4.6.x and will update. – petednz - fuzion Aug 12 '15 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.