1

[Edited from original question]

When editing a custom field group for Individuals that allows multiple records, the Display Style option changes from Tab with table to Inline. Seems like a regression/bug.

On two different instances of Civi 5.67.3, when I used the UI to edit one of my custom field groups, it inadvertently changed to Inline display style. I was able to revert the display style back by setting civicrm_custom_group.style in the db back to Tab with table.

The front-end display of the custom field seems to work fine. It's just this backend custom field group edit form that seems to be the issue.

Civi 5.67.3 Shoreditch theme Drupal 10.1.6


Update #1

Here's a screenshot of the Edit Custom Field popup screen, showing that the group is set to allow multiple records and yet the display option doesn't show Tab with Table.

I don't see any javascript errors in the browser console.

enter image description here

I cannot replicate this on dmaster, so perhaps it's a localized issue.


Update #2

The weirdness on the edit custom group screen is happening only when there are actual records for that custom group.

Here's a custom group when there are NO records (after initial creation, or after adding and then deleting a custom field entry for an Individual).

enter image description here

And here's the same custom group when I add 1 record to an Individual.

Strange behaviors:

  1. It's missing the fields: maximum number of multiple records
  2. Under Display Style the Tab with table option is missing.

The Tab icon is missing because in the screenshot below it's set to Inline but shows up again if you select Tab, so that's working ok.

enter image description here

The edit screen shows the same weird behavior for custom groups allowing multiple records set to the other display styles (Tab, Inline), so it seems the issue is isolated to custom groups that allow multiple records and have at least one data entry.

Still trying to make heads or tails of this. I appreciate any insights.

1 Answer 1

1

Tab with Table I believe is only an option if you have selected "Does this Custom Field Set allow multiple records?"

Confirmed on dmaster

enter image description here

7
  • Yes, good point! I updated my question to make it more specific. I am experiencing the issue when editing the cf groups that allow multiple records.
    – Justin657
    Dec 14, 2023 at 20:27
  • @Justin657 Note your screenshot also doesn't have the "maximum number" field. Can you tell us more about the custom group details?
    – Demerit
    Dec 14, 2023 at 21:07
  • @Demerit - Yes indeed, "maximum number" field is missing. I added Update #2 to my question adding more details.
    – Justin657
    Dec 15, 2023 at 16:41
  • That seems wacky. I can't reproduce it. Do you have any relevant extensions that might be altering it? What data type is the custom field itself (may or may not be relevant)?
    – Demerit
    Dec 15, 2023 at 18:25
  • did you replicate all of that on dmaster.demo.civicrm.org
    – petednz - fuzion
    Dec 15, 2023 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.