1

Enabling the debug mode, I got more details:

Error Field Error Value Type DB_Error Code -18 Message DB Error: no such table Mode 16 UserInfo UPDATE civicrm_afform_submission SET contact_id = 123 WHERE contact_id = 456 [nativecode=1146 ** Table 'wordpress.civicrm_afform_submission' doesn't exist] DebugInfo UPDATE civicrm_afform_submission SET contact_id = 123 WHERE contact_id = 456 [nativecode=1146 ** Table 'wordpress.civicrm_afform_submission' doesn't exist]

It looks like this table is created by the Form Builder extension. I tried to enable it but the table is still not created.

1 Answer 1

2

Can you uninstall the extension and re-install?

i.e Disable >> Uninstall >> Install

Or you can run below query

CREATE TABLE `civicrm_afform_submission` (
  `id` int unsigned NOT NULL AUTO_INCREMENT COMMENT 'Unique Submission ID',
  `contact_id` int unsigned,
  `afform_name` varchar(255) COMMENT 'Name of submitted afform',
  `data` text COMMENT 'IDs of saved entities',
  `submission_date` timestamp DEFAULT CURRENT_TIMESTAMP,
  `status_id` int unsigned NOT NULL DEFAULT 1 COMMENT 'fk to Afform Submission Status options in civicrm_option_values',
  PRIMARY KEY (`id`),
  CONSTRAINT FK_civicrm_afform_submission_contact_id FOREIGN KEY (`contact_id`) REFERENCES `civicrm_contact`(`id`) ON DELETE SET NULL
)
ENGINE=InnoDB ROW_FORMAT=DYNAMIC;
2
  • Thanks! Reinstalling the extension didn't work. I had to create the table manually. But why this extension is required for merge action? And if it's required, why it's not activated by default? Jan 10 at 12:01
  • 1
    Ah, the problem only happens when the Form Core ext is activated and the Form Builder not. Jan 10 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.