0

My Edit Line Item extension stopped working. It looks like it needs an update, but update fails with the error "You will not be able to install/upgrade Edit Line Item Extension until you have installed the org.civicrm.afform extension".

On the face of it, it seems I have exactly this same problem (Can't upgrade Mosaico Extension from 2.8XXXX to 2.9 without Afform but no Afform Ext. Available in Joomla)

But I do have Form Core installed and up to date (I think? says it's a prerelease version).

Details: Joomla CiviCRM 5.66.1 Edit Line Extension v2.6 (wants upgrade to 2.7) Form Core 5.66.1

Based on other research, it seems Afform/Form Core was an external extensions that became part of core? So maybe this is an out of date dependency problem? Anyway, how do I fix it? Do I simply need to update Civi to the latest?

Thanks as always!

1 Answer 1

2

Afform is shipped with core and is now automatically enabled. I'd upgrade Civi then try again.

2
  • Thanks Aidan, will do so today and see how it goes.
    – minbori
    Jan 16 at 9:44
  • It took a while but eventually I did update Civi to 5.70.0, and was able to install the extension. (The extension itself isn't working properly, but that's another issue....)
    – minbori
    Feb 20 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.