3

We have a Drupal 7 site which is days away from being ready to migrate to Drupal 10.
Mapping the final rollover process in a dev environment, I had planned to upgrade CiviCRM on the D7 site to current, from 5.65.1 to 5.69.2.
The CiviCRM upgrade reported and appeared to be fine, and I opted to implement the recommended Smarty3.

Unfortunately all Drupal Views (eg Custom Formatted lists of events for registration) are now broken.

  • When viewed, the Views show no results.
  • When edited, all Fields display "Broken/missing handler".
  • When attempting to add a new view, no CiviCRM entities are visible.

Has anyone else encountered this, and any suggestions?

I'll be rolling back and investigating whether deferring the CiviCRM upgrade until after Drupal is at v10 works better due to entity handling.


Solved: For reasons that are still a mystery to me, installing the Drupal module civicrm_entity resolved this. The site has been running for years through many CiviCRM updates and this is the first time it's needed this. It seems to be required for any version newer than 5.65.1.

Hopefully this can save someone else a few hours work if they encounter the same thing!

2
  • Thank you @AlexT! Please choose "Answer your own question", move your solution into an answer, and mark it as accepted? This will make it clearer to others that a solution exists. Also - Drupal 10 does CiviCRM Views fundamentally differently, and civicrm_entity is a requirement (Civi entities are registered as Drupal entities, instead of doing trickery in settings.php). So this is the better solution for you moving forward regardless. Jan 19 at 16:17
  • Thanks Jon G. Yes I was definitely using civicrm_entity already for Drupal 10, and it is way nicer that the old ways! I just hadn't expected it to become essential in Drupal 7 when upgrading CiviCRM only. Underway on the D10 upgrade now!
    – AlexT
    Jan 20 at 17:25

1 Answer 1

2

Solved: For reasons that are still a mystery to me, installing the Drupal module civicrm_entity resolved this. The site has been running for years through many CiviCRM updates and this is the first time it's needed this. It seems to be required for any version newer than 5.65.1.

Hopefully this can save someone else a few hours work if they encounter the same thing!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.