0

I do not generally work on WordPress but I am trying to help a friend. I have a WordPress 6.4.2 site with CiviCRM 5.69.2 and PHP 8.2.3.

Since upgrading PHP when trying to bootstrap the site I get the following error:

TypeError thrown with message "Symfony\Component\EventDispatcher\EventDispatcher::dispatch(): Argument #2 ($event) must be of type ?Symfony\Component\EventDispatcher\Event, string given, called in /var/www/html/wp-content/plugins/civicrm/civicrm/Civi/Core/CiviEventDispatcher.php on line 263"

This sname error was discussed in relation to Drupal 10 with https://lab.civicrm.org/dev/core/-/issues/2316. A PR was created and appears to be merged https://github.com/civicrm/civicrm-core/pull/19960 but I am still having this problem.

I am running this instance of the site using ddev on my local computer.

Any help on how to approach this is greatly appreciated.

Thanks!

1
  • Is there a stack trace? There might be an extension or wordpress plugin that bundles an older version of symfony and so there are two conflicting versions.
    – Demerit
    Jan 21 at 22:07

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.