1

This has come up a few times on SE but I've not found a working solution yet.

WP 6.4.3 / CiviCRM 5.68.1 - hosted on Cloudways / DigitalOcean (not sure that's relevant)

Upgrading to 5.69 and I got the Queue runner error - I figured it was a CiviCRM upgrade issue with the WP version, so rolled back and waited for 5.70

Still have the error (output below).

I've tried refreshing cache from the WP CiviCRM setting tab and I've tried deleting the entire of civicrm_cache from the WP_DB. Regular cron jobs are working fine. I'm going to ask the Cloudways tech team to install cv so I can try a command line cv upgrade:db but I'm not optimistic at this point.

Any suggestions / solutions?

[Error: undefined]
Exception: "Queue runner must be configured before execution."

#0 /home/***/public_html/wp-content/plugins/civicrm/civicrm/CRM/Queue/ErrorPolicy.php(93): CRM_Queue_Page_AJAX::{closure}()
#1 /home/***/public_html/wp-content/plugins/civicrm/civicrm/CRM/Queue/Page/AJAX.php(38): CRM_Queue_ErrorPolicy->call()
#2 /home/***/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(288): CRM_Queue_Page_AJAX::runNext()
#3 /home/***/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(69): CRM_Core_Invoke::runItem()
#4 /home/***/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(36): CRM_Core_Invoke::_invoke()
#5 /home/***/public_html/wp-content/plugins/civicrm/civicrm.php(1231): CRM_Core_Invoke::invoke()
#6 /home/***/public_html/wp-includes/class-wp-hook.php(324): CiviCRM_For_WordPress->invoke()
#7 /home/***/public_html/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters()
#8 /home/***/public_html/wp-includes/plugin.php(517): WP_Hook->do_action()
#9 /home/***/public_html/wp-admin/admin.php(259): do_action()
#10 {main}
2
  • 1
    CiviCRM 5.69+ has proper WP-CLI support - and WP-CLI might already be installed, if not then it's pretty easy wp-cli.org/#installing - so you could try wp civicrm core update-db --vv instead? Feb 19 at 10:09
  • thanks - will try that this evening Feb 19 at 10:47

1 Answer 1

1

Solved

wp civicrm core update-db --vv

CiviCRM 5.69+ has proper WP-CLI support - and WP-CLI might already be installed, if not then it's pretty easy wp-cli.org/#installing - so you could try wp civicrm core update-db --vv instead?

Thanks @Christian

1
  • Happy to hear it worked for you John. Feb 20 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.