1

we've just set up our first event in a year and I've just realized it's not possible to change the selections of any participant in the admin backend.

The registration process itself works fine. Participants register through a CiviEvent online registration form in the frontend. But making backend changes to existing registrations isn't possible.

I can view or edit the participant record, and there is a "Change selections" button where I expect it. But when the "Change Selections" is clicked, the "Change Registration Selections" window opens as expected, but there simply is no list of other options shown. So there are no options to change or select. The window shows the current selections, then goes right to "Payment Confirmation" section. See below:

enter image description here

There are no errors in the browser console, and no errors in the ConfigDebug log. The functionality simply isn't there.

As it's been a while since our last event, and I have made several upgrades since last time, I have no idea when this functionality disappeared; it was working for our event in March 2023. I was hoping this was a version issue, so I've just upgraded to Civi 5.70.0. But the issue still persists.

System info: Joomla 3.10 CiviCRM both 5.66.1 and 5.70.0

4
  • Can you reproduce the problem on dmaster.demo.civicrm.org ?
    – Aidan
    Feb 20 at 21:51
  • No, that works fine as petednz mentions below. I wanted to try on the Joomla demo but that seems to be offline :-(
    – minbori
    Feb 21 at 8:27
  • 1
    Do you have custom tpl or php override or any extension related to priceset/lineitem/participants etc? Feb 23 at 15:12
  • PRADEEP! I think you may have just saved my life. I had thought about the extensions and had tested with them deactivated. But I had forgotten about some old custom PHP code. Removed it, and it seems things are working again!!!! Would you like to put this in the form of an answer so I can give you the bounty?
    – minbori
    Feb 24 at 15:45

2 Answers 2

2

It's buried in the comments, but I wanted to put a conclusion here -- in the end it was some forgotten custom PHP code that was the culprit. Thank you Pradeep for the suggestion, sorry I couldn't give you the bounty!

1

Attempted to replicate on dmaster.

https://dmaster.demo.civicrm.org/civicrm/contact/view/participant?reset=1&action=update&id=42&cid=77

enter image description here

Click through to change selection gives me this url

https://dmaster.demo.civicrm.org/civicrm/event/participant/feeselection?reset=1&id=42&cid=77&action=update

and this screen

enter image description here

is there anything about what I have done that is incorrect, as currently it seems like it does deliver the expected outcome

if the problem on your site cannot be replicated on eg dmaster or one of the other demo sites then perhaps worth using Inspect to see if you can see any console errors

16
  • Yes, that is exactly the procedure I use on my instance. This one used to in the past but somehow doesn't now. Clicking through the change selection button gives me the expected URL (DOMAIN.org/administrator/?option=com_civicrm&task=civicrm/…), but the page that is delivered is just missing the middle section (there aren't even any empty HTML tags marking its absense). I'm just not even sure where to start troublehshooting this -- no errors in console, nothing in logs.
    – minbori
    Feb 21 at 8:25
  • FYI I've also tried to reproduce on the Joomla demo, but it seems to be currently offline.
    – minbori
    Feb 21 at 8:25
  • Further analysis: I've tested this on another Joomla instance I manage and it's working fine. And I've been able to compare the HTML produced for both screens. In the broken version, the HTML element fieldset#priceset.priceset-group that should exist between the table.form-layout containing the Participant block and the fieldset#email-receipt block simply isn't there.
    – minbori
    Feb 21 at 8:49
  • I thought it might be a permissions issue, but I'm testing this with the super admin and ALL CiviCRM CMS permissions are granted. There aren't any Civi ACL permissions.
    – minbori
    Feb 21 at 8:52
  • Replace the file /administrator/components/com_civicrm/civicrm/templates/CRM/Event/Form/ParticipantFeeSelection.tpl in your non-working installation with the same file from the working installation.
    – Guitarman
    Feb 21 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.