2

We have an import that we do a few times a year that I set up about 2 years ago. Until today, it's never had an issue. We are using v4.6.3, and the last time we did it we were using a 4.5.x version.

When importing households, we have some custom relationships defined. They are Individual to Household relationships. These relationships do not show up in the selector for the mapping the imported data. Some relationships DO show up; Household member and Head of Household, plus two other relationships in which contact a type is not set.

The relationships that don't show up are useable in all other contexts that I have tried. They are enabled. I have gone so far as to compare the relationship type records in mysql and I see no obvious issues.

I've also searched the Jira to see if there's a known issue but I don't see any.

Suggestions?

  • I have duplicated this on the demo.civicrm.org site. The relationships do not show up during Import when they are a "subtype" of household. So: Create a subtype of household "Household subtype"; Create a relationship where type "a" is Individual and "b" is the new subtype above; Import a csv for Household, select the subtype. On the next page you will not be able to select the new relationship type in order to designate an identifier. – Rob Brandt Aug 12 '15 at 23:43
  • Rob do you want to confirm if this is an issue only related to Households? Ie do the subtype options show if you were importing where Contact A and B were both Individuals?Households don't get used as much so perhaps it missed out on some code/love. – petednz - fuzion Aug 13 '15 at 0:47
  • Well, shoot. Now I can't replicate the problem. I tried adding subtypes for each main type, then adding relationships between each type and new subtype (9 in all) and all 9 worked. Any chance this was fixed last night? The demo does say it's running 4.6.7. – Rob Brandt Aug 13 '15 at 16:47
1

We are having the same problem with relationship imports that have custom subtypes. Our subtypes are Individual - Student and Organization - School. The relationship is Student of (Student) - Student for (School).

The relationship does not show up for mapping during import. My testing shows that it's the first part (a) that causes it not to show up. If the (a) is changed to Individual it will show up, all other combinations do not.

I have also verified that this relationship does show up in 4.5.4. This is the only 4.5.x version I could readily test with. I have verified on the demo test as well.

I have created an issue: https://issues.civicrm.org/jira/browse/CRM-17544

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.