0

We are venturing into event registrations in CiviCRM (version 5.65.2) for the first time. On our form, there are a series of address fields tied to an Individual contact type. The fields show properly and work together when I'm logged in, but when I bring up the form as an anonymous user (which we want to allow), things don't work. You can change the Country field, but the State field never adjusts from its disabled state showing "Choose country...". There are no errors in the browser's console. What are we missing? How do we fix this?

screenshot of address fields on form

Updated 26-FEB-2024

  1. CiviCRM is installed in WordPress.
  2. The fields in question are profile fields. Here is a screenshot of the back-end setup of those fields:

screenshot of profile fields

7
  • Can you check the Permissions and confirm if Anon has "CiviCRM: access AJAX API" in case that is required to load the State data after the Country data?
    – petednz - fuzion
    Commented Feb 26 at 2:16
  • Check you have the same location for the state and the country fields. If they are different, it breaks Commented Feb 26 at 8:50
  • What form is that? Event Online form with profiles having address fields? If this is a Drupal site, have you tried using webform civicrm? Commented Feb 26 at 12:59
  • @petednz-fuzion where do I check the permissions for an event registration form? This isn't formbuilder.
    – Mark
    Commented Feb 26 at 22:32
  • @jitendra-fuzion yes, event online form with profiles having address fields. The site uses WordPress. I'll update my question with a screenshot of the backend setup for those fields.
    – Mark
    Commented Feb 26 at 22:32

1 Answer 1

0

Please check, if the desired countries and states/provinces for your form are configured correctly. You find theses settings in "Administer > Localization > Languages, Currency, Locations". There you will have to select the countries/states/provinces that should be available to choose from for your registration form.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.