0

So this weekend I purchased hosting via CiviHosting for a WP/CiviCRM setup. Most things have been setup without much issue, however, Mosaico will not install. It fails with a rather generic, 'DB Error: Syntax error'.

Mosaico Install version is 3.5.1709296836
Civi is version 5.67.0
WP is version 6.4.3
PHP is 8.3.2
MySQL is v8.0.35

Its not likely related, but I was also unable to install CiviVolunteer, though in troubleshooting that it appears to be on borrowed time.

Here is error log:

    2024-03-04 04:05:01+0000  [error] 
$Fatal Error Details = array:3 [
  "message" => "DB Error: syntax error"
  "code" => null
  "exception" => CRM_Core_Exception {#3165
    #message: "DB Error: syntax error"
    #code: -2
    #file: "/home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/api/api.php"
    #line: 138
    #cause: null
    -_trace: null
    -errorData: array:8 [
      "error_code" => -2
      "sql" => ":  Undefine_e112a5f4_after_insert"
      "debug_info" => """
        DROP TRIGGER IF EXISTS civicrm_value_civivolunteer_\n
        :  Undefine_e112a5f4_after_insert [nativecode=1064 ** You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ':  Undefine_e112a5f4_after_insert' at line 2]
        """
      "entity" => "Extension"
      "action" => "install"
      "is_error" => 1
      "error_message" => "DB Error: syntax error"
      "debug_information" => ":  Undefine_e112a5f4_after_insert"
    ]
    trace: {
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/api/api.php:138 {
        civicrm_api3(string $entity, string $action, array $params = [])
        › if (is_array($result) && !empty($result['is_error'])) {
        ›   throw new CRM_Core_Exception($result['error_message'], CRM_Utils_Array::value('error_code', $result, 'undefined'), $result);
        › }
      }
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Admin/Form/Extensions.php:187 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Form.php:614 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/StateMachine.php:144 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/QuickForm/Action/Next.php:43 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Controller.php:203 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Page.php:103 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php:355 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Page/Basic.php:364 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Page/Basic.php:170 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Admin/Page/Extensions.php:110 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:322 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:69 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:36 { …}
      /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm.php:1199 { …}
      /home/friendsofthe/www/www/wp-includes/class-wp-hook.php:324 { …}
      /home/friendsofthe/www/www/wp-includes/class-wp-hook.php:348 { …}
      /home/friendsofthe/www/www/wp-includes/plugin.php:517 { …}
      /home/friendsofthe/www/www/wp-admin/admin.php:259 { …}
    }
  }
]


2024-03-04 04:05:01+0000  [debug] $backTrace = #0 /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(443): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(39): CRM_Core_Error::handleUnhandledException(Object(CRM_Core_Exception))
#2 /home/friendsofthe/www/www/wp-content/plugins/civicrm/civicrm.php(1199): CRM_Core_Invoke::invoke((Array:3))
#3 /home/friendsofthe/www/www/wp-includes/class-wp-hook.php(324): CiviCRM_For_WordPress->invoke("")
#4 /home/friendsofthe/www/www/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters("", (Array:1))
#5 /home/friendsofthe/www/www/wp-includes/plugin.php(517): WP_Hook->do_action((Array:1))
#6 /home/friendsofthe/www/www/wp-admin/admin.php(259): do_action("toplevel_page_CiviCRM")
#7 {main}
5
  • Have you raised a ticket with CiviHosting? They are very helpful.
    – Andy Clark
    Mar 4 at 8:43
  • Ticket raised — first response was that it looked like a CiviVolunteer bug. CiviVolunteer never installed fully as it had a DB error too. I cannot remove nor install it either — it seems I’ve not been able to install anything since then.
    – Ben
    Mar 4 at 19:09
  • CiviHosting removed CiviVolunteer and suggested a remove/reinstall of CiviCRM entirely as it's brand new. Deleted the Plugin and database, reuploaded Civi via wordpress plugin gui without issue. However, a fatal error was thrown when installing... Waiting on suggestion from CiviHosting on next steps...
    – Ben
    Mar 5 at 5:12
  • Do you get the same problems if you use php 8.1 or 8.2?
    – Aidan
    Mar 5 at 12:17
  • I don’t believe I have the option to change this, however CiviHosting reinstalled for me and I’ll try again. Thx
    – Ben
    Mar 5 at 14:24

1 Answer 1

0

No solution found — As this was an a new install and not yet populated, CiviHosting deleted CiviCRM and reinstalled for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.