1

I am attempting to install CiviCRM on a Drupal 10 website. The composer instructions seem to have downloaded the software just fine, and it all looks reasonable, but when I put in cv core:install --cms-base-url="https://dev,wis.communty" --db="mysql://myusername:mypassword@localhost:3306/dev_civicrm"

I get back the error Failed to parse or find a CMS null

I am not at all sure what that is telling me or how to proceed.

If I run it in verbose mode I get: Box Requirements Checker

Using PHP 8.1.27 PHP is using the following php.ini file: /etc/opt/remi/php81/php.ini

Checking Box requirements: ✔ The application requires a version matching ">=7.3.0". ✔ The application requires the extension "json". ✔ The package "psy/psysh" requires the extension "json". ✔ The package "nikic/php-parser" requires the extension "tokenizer". ✔ The package "psy/psysh" requires the extension "tokenizer".

[OK] Your system is ready to run the application.

[BootTrait:debug] Call CMS bootstrap [CmsBootstrap:debug] Options: { "env": "CIVICRM_BOOT", "search": true, "httpHost": "localhost", "user": null, "output": {} } [CmsBootstrap:debug] Find CMS... [CmsBootstrap:debug] CMS: null

In CmsBootstrap.php line 66:

[Exception]
Failed to parse or find a CMS null

Exception trace: at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/lib/src/CmsBootstrap.php:66 Civi\Cv\CmsBootstrap->bootCms() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/lib/src/Util/BootTrait.php:100 Civi\Cv\Command\CoreInstallCommand->_boot_cms_only() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/src/Util/SetupCommandTrait.php:22 Civi\Cv\Command\CoreInstallCommand->bootSetupSubsystem() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/src/Command/CoreInstallCommand.php:47 Civi\Cv\Command\CoreInstallCommand->execute() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/vendor/symfony/console/Command/Command.php:127 Cvphar\Symfony\Component\Console\Command\Command->run() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/vendor/symfony/console/Application.php:637 Cvphar\Symfony\Component\Console\Application->doRunCommand() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/vendor/symfony/console/Application.php:190 Cvphar\Symfony\Component\Console\Application->doRun() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/src/Application.php:67 Civi\Cv\Application->doRun() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/vendor/symfony/console/Application.php:101 Cvphar\Symfony\Component\Console\Application->run() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/src/Application.php:33 Civi\Cv\Application::main() at phar:///home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar/bin/cv:28 require() at /home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/extern/cv.phar:14 require() at /home/wis/domains/dev.wis.community/public_html/vendor/civicrm/cli-tools/bin/cv:7 include() at /home/wis/domains/dev.wis.community/public_html/bin/cv:119

core:install [--settings-path [SETTINGS-PATH]] [--setup-path [SETUP-PATH]] [--src-path [SRC-PATH]] [--plugin-path [PLUGIN-PATH]] [--cms-base-url [CMS-BASE-URL]] [--lang [LANG]] [--comp [COMP]] [--ext [EXT]] [--db [DB]] [-m|--model [MODEL]] [-A|--abort] [-K|--keep] [-f|--force] [--debug-event [DEBUG-EVENT]] [--debug-model] [--level LEVEL] [--hostname HOSTNAME] [-t|--test] [-U|--user USER]

1 Answer 1

3

Oops. Found the problem. I somehow had a comma in the url rather than a period. Worked fine after I fixed that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.