1

Issue resolved Graham and Jon G pointed me to the solution. When the SSL cert was installed after CiviCrm, there was a mix of HTTP and HTTPS references in the relevant PHP files. I installed the SSL cert to the Domain prior to activation CiviCrm, and it is functioning without issue and SSL is enabled. Thank you!

Initially the system status menu and and all others appear correctly but on second look at the CiviCRM from Wordpress dashboard the menus are displayed as text only with links that work, but menus are corrupted in same way. (believe same issue on previous install CiviCRM 5.70, but now need to verify this)

The Civi menu selection is not available in the header of the page. I have cleared cache thru Admin tools and browsers. Located civicrm.settings.php in ~/wp-content/uploads/civicrm and verified 'wp.frontend.base', 'wp.backend.base' URLs and 'domain' 'userFrameworkResourceURL' contain the correct IP.

My use of CiviCRM until now has been Spark hosted; I'm setting up an AWS instance with Bitnami/Automattic AMI. I have setup this instance from scratch several times, same result. I must be missing something obvious. No other plugins activated, or other plugins activated, same result as well.

I just located this old question: Word Press Install Missing civicrm.settings.php; dashboard unavailable; no menus, which gave me two clues. The addition of the SSL Cert, and a secondary civicrm.settings.php, that may not have been correctly updated. I'm going to try install again to verify impact of the SSL Cert on the issue (I just can't remember its install's relation to the menus).

Update: Reinstall to verify state of menus before SSL Cert; issue still exists.

update #2: Failed to resolve issue. Reverted to CiviCRM 5.71.0 and there is not any issue with the menus. I will now be exceptionally careful to note each change from SSL cert to plug-in activations and report back if issue recurs in this version.

Update 3: Installed new instance of the Bitnami Wordpress and installed CiviCRM 5.71.0. All was well until I installed the "Let's Encrypt" SSL Cert, which broke the CiviCrm menus. I'm now going to work without the SSL and later attempt install of SSL cert differently. No System Status

Admin not a drop-down

3
  • 1
    Could you please be specific about what you mean by "corrupted"? Do you mean that the icons are missing?
    – Coleman
    Mar 10 at 18:48
  • I'd get wordpress up and running with the SSL cert in place and working before trying to install CiviCRM.
    – Graham
    Mar 12 at 18:05
  • Thank you, Graham. An elegant solution if it works...then the subsequent setting files of Civi would all have HTTPS rather than HTTP from the get-go. I'll report back.
    – Datatribe
    Mar 13 at 13:40

1 Answer 1

0

Without more info it's hard to say, but you very likely have a CORS issue. This happens when not all of your assets (images, fonts, etc.) are loaded from the same URL as the one you visit. "Same URL" includes not just the domain, but the protocol (e.g. http://, https://) and port number.

In all likelihood, you were loading some assets (either fonts or Javascript) over HTTP. You can confirm this by opening your browser's Developer Tools (press "F12" on your keyboard) and viewing the Network tab. But the easiest solution to this is to force all HTTP requests over HTTPS.

2
  • 1
    Thank you for that lead, Jon G.
    – Datatribe
    Mar 13 at 13:37
  • I had a CORS issue earlier in the day yesterday, so the symptoms were fresh in my mind. Glad I could help! Mar 14 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.