0

I am volunteering for a nonprofit and they are using WordPress. Almost all my CiviCRM experience is in Drupal so I am having a bit of trouble. We just created a new site to house WordPress and it is version 6.4.3. We are running PHP 8.1.27. I am trying to use CiviCRM 5.67.3.

Right now I am doing a fresh install and then I am going to bring over our existing database. We are using 5.67.3 because the current database is on 5.67.1.

This is all I see when I load CiviCRM on the admin side. WordPress admin screen that says "CiviCRM Home" and then has the CiviCRM footer but no other CiviCRM content. In the screenshot you can see the WordPress admin screen that says "CiviCRM Home" and then has the CiviCRM footer but no other CiviCRM content.

Clicking on the System Status Error link simply reloads the page.

I am able to get to wp-admin/admin.php?page=civi_options.

I have tried clearing the cache from the UI and from CV.

The instance of CiviCRM was installed from cv version v0.3.27.

Any help figuring this out is greatly appreciated.

Thanks, Steve

5
  • Can you confirm what instructions you followed for moving a civicrm Db from Drupal to civicrm? This docs.civicrm.org/sysadmin/en/latest/misc/switch-servers?
    – petednz - fuzion
    Commented Mar 18 at 18:35
  • I have not done that part yet. I am first trying to just do a new install and make sure I know all the paths in the settings file before moving over. Thanks!
    – Steve
    Commented Mar 19 at 0:22
  • ah right. sorry misunderstood. so this is a clean WP with civi install, and you need help figuring why the civi install doesn't seem to have worked? if so then I am not someone who can be of much help
    – petednz - fuzion
    Commented Mar 20 at 1:12
  • Thanks for look at this, I appreciate it.
    – Steve
    Commented Mar 22 at 4:15
  • WordPress is pretty cut and dry - been running it and Civi for years. Install WP, and then install the Civi plugin from the WP plugin library. Couple things I would look at: First, delete it all out including the db's. Second, make sure that your PHP is 8.1.x Third install the CiviCRM Admin Utilities plugin as it does a bunch of cool things. Not in here a lot, but try that and I will check back later. Commented Mar 29 at 10:19

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.