3

Returning from paypal, with debug enable, there is nothing shown and it says that an e-mail should be sent, but no email is received

CiviCRM 4.6.5 and WordPress 4.2.4

When the payment processor Paypal Standard is chosen, the receipt is not being sent.

When returning from paypal, it goes onto the thank you page and the payment is marked as completed, so everything is fine for the payment processor.

When I choose "Pay later", the receipt is sent so the e-mail processor is fine too.

What could cause this issue?

Seems related to this issue: https://issues.civicrm.org/jira/browse/CRM-15629

But it was supposed to be fixed in 4.6.3

Thanks.

This is what I get in the ConfigAndLog file:

Aug 25 12:00:17 [info] Contribution record updated successfully

Aug 25 08:00:21 [info] $Fatal Error Details = Array ( [message] => [code] => )

Aug 25 08:00:21 [info] $backTrace = #0 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(364): CRM_Core_Error::backtrace("backTrace", TRUE) #1 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/DAO.php(1018): CRM_Core_Error::fatal() #2 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Contribute/Form/Task/Invoice.php(478): CRM_Core_DAO::getFieldValue("CRM_Contact_DAO_Contact", NULL, "display_name") #3 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Contribute/BAO/ContributionPage.php(922): CRM_Contribute_Form_Task_Invoice::printPDF((Array:1), (Array:2), (Array:1), NULL) #4 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/BAO/MessageTemplate.php(508): CRM_Contribute_BAO_ContributionPage::addInvoicePdfToEmail("398", "2") #5 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Contribute/BAO/ContributionPage.php(412): CRM_Core_BAO_MessageTemplate::sendTemplate((Array:13)) #6 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Contribute/BAO/Contribution.php(2291): CRM_Contribute_BAO_ContributionPage::sendMail("2", (Array:36), FALSE, FALSE) #7 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Payment/BaseIPN.php(853): CRM_Contribute_BAO_Contribution->composeMessageArray((Array:28), (Array:9), (Array:36), FALSE, FALSE) #8 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Payment/BaseIPN.php(788): CRM_Core_Payment_BaseIPN->sendMail((Array:28), (Array:9), (Array:7), (Array:36), FALSE, FALSE) #9 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Payment/PayPalIPN.php(290): CRM_Core_Payment_BaseIPN->completeTransaction((Array:28), (Array:9), (Array:7), Object(CRM_Core_Transaction), FALSE) #10 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Payment/PayPalIPN.php(343): CRM_Core_Payment_PayPalIPN->single((Array:28), (Array:9), (Array:7), FALSE, FALSE) #11 /home2/sherbro3/public_html/wp-content/plugins/civicrm/civicrm/extern/ipn.php(52): CRM_Core_Payment_PayPalIPN->main() #12 {main}

  • Seems like an issue with the PayPal IPN not being received? ps: updated the title because seems like this is from CiviContribute, and using PayPal Standard, which is very different from PayPal Pro. – bgm Aug 19 '15 at 15:59
  • Forgot to mention: IPNs should be logged in the ConfigAndLog directory of CiviCRM. – bgm Aug 19 '15 at 16:10
  • 1
    Actually you will see entries in civicrm_system_log table for ipns – eileen Aug 19 '15 at 21:32
  • The IPN is received by CiviCRM since the payment is marked as complete. Where can I see the IPN log, not sure I understand. – Francis Poisson Aug 24 '15 at 15:02
  • I have updated to CiviCRM 4.6.7 and Wordpress 4.3. Still the same thing. – Francis Poisson Aug 25 '15 at 11:59
2

This patch fixes the problem for me: https://github.com/civicrm/civicrm-core/pull/6900

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.