1

I'm managing an installation of CiviCRM 5.69.1 on Wordpress 6.4.3. A CiviCRM contribution page has been working fine for years, but we've just noticed that some custom member profile text fields -- for example, Spouse Name -- are prefilling on the contribution/membership signup page with a specific member's values when a new person goes to sign up on their own computer. I've cleared caches and tested in several browsers. These fields have no default values in their settings, and if I do set a default value, it does not override this prefilled data. Anyone have any idea why this is happening and how I can fix it?

4
  • Hi Jody - can you paste examples (hide your domain if you want) of the pages people are visiting where this happens, and can you confirm that this is occuring when the user is anonymous (ie not logged in)
    – petednz - fuzion
    Apr 4 at 18:19
  • Hi, thanks for your reply. This is occurring for anonymous users; a visitor without a login reported it, and I confirmed it in multiple browsers where I wasn't logged in. The Civicrm path is: /civicrm/contribute/transact?reset=1&id=2 I'll be glad to provide the full path privately. I have temporarily disabled the two pre-filling fields since they are name fields with private data. They are always filling with the same non-admin member's info.
    – Jody F.
    Apr 5 at 12:19
  • @jody if you send me the URL on chat.civicrm.org (I'm @junglebird) I could take a quick look. This is very unusual - if you could also send me the list of installed extensions (Administer > System Settings > Extensions) I'm guessing there's a rogue one in there. I'm having a hard time imagining how this could be happening without extensions. Apr 6 at 17:07
  • Could it happen if there was an incorrect entry in uf_match table - and that in fact all these submissions are overwriting each others data for that one cid?
    – petednz - fuzion
    Apr 6 at 20:56

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.