1

I'm getting the error "Queue runner must be configured before execution" when importing a list of contacts. The file is just a single column of 416 emails. I've tried the advice given elsewhere on SE to run "cv upgrade:db" but it just responds (correctly) that the system is already upgraded to 5.71.2, and the error continues. I don't see anything relevant in the logs. This is on WP 6.5. Any advice?

1 Answer 1

1

Could this be a site with some redirection around ssl or www vs no www ?

Generally the code is looking for qrid in the url to figure out the Queue ID and then it's looking in the $_SESSION to find what the user kicked off - so maybe something in the user session is being lost. Def a hard one to debug.

It is possible to process the queue in the background - but that requires setting up a server process.

Could it be some interaction with a plugin or extension?

2
  • I am not aware of any redirection around ssl or www vs no www. Also, we have had issues with interaction with another plugin in the past, but I think that is resolved finally. Can you point me to a doc about setting up a server process to handle the queue in the background? Thanks.
    – twowheeler
    Apr 24 at 0:44
  • So to run queues in the background there is a utility called 'coworker' that you can install lab.civicrm.org/dev/coworker - to push import jobs to the queue you need to enable a setting too We have been using this for large jobs (e.g 500k rows that import over a period of days)
    – eileen
    Apr 26 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.