1

What would cause CiviCRM to truncate the dynamic CiviCRM URL for public users, but load the correct one for logged-in ones?

For the public, this URL: https://domain.org/civicrm/contribute/transact/?reset=1&id=x loads as: https://domain.org/civicrm/

... so instead of the contribution form, it loads the CiviCRM base page for public users. The permissions are set correctly so they should be able to view the form.

WordPress 6.5.2 CiviCRM 5.70.1 Server running AlmaLinux

2
  • This may be related to your CMS rather than CiviCRM so it would be helpful if you could edit your question to include details of this - i.e. is it Drupal, WordPress or Backdrop or Joomla? Also versions of both the CMS and CiviCRM would be helpful. Commented Apr 14 at 11:14
  • 1
    System info added. Thanks for the reminder.
    – Sarah
    Commented Apr 14 at 12:41

2 Answers 2

3

Problem solved: The Yoast SEO plugin was set to rewrite dynamic URLs under the Advanced -> Crawl Optimization settings. Disabling it fixed the issue.

1
  • Glad to hear it!
    – themak
    Commented Apr 22 at 15:30
1

This may be a permalinks issue - if you are a wordpress and CiviCRM user - go to your permalinks page (settings, permalinks) and simply let it load - if you would like, you can also click save changes without making changes, but my understanding is just loading the page fixes the problem.

I usually like to clear all caches before and after I do this, but its not necessary.

As a CiviCRM / Wordpress Admin, you will find this to be a common page you visit when troubleshooting.

1
  • Already tried this and it's not the issue. When I'm logged in as admin, the links resolve correctly. The rewriting occurs for logged-out users only. My IP is whitelisted in the firewall so it's not due to IP filtering. Still trying to find the reason. It used to work fine. The only change on the server was a kernel upgrade by the server techs around the timeframe when it stopped working. That's way beyond my technical expertise.
    – Sarah
    Commented Apr 21 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.