0

We're in the midst of upgrading (5.69 > 5.71), and I noticed that when viewing a case, if I click on Print Report, none of the custom fields appear on the print view on our 5.71 dev site. They appear fine on our 5.69 production site.

I've checked several of the demo sites available, and I see them there sometimes and not other times, but I can't consistently see the version numbers on the demo sites to know what I'm actually comparing.

I'm just trying to determine if this is a general problem or a just-us problem. Thanks!

4
  • The version number appears at the bottom of every civi page.
    – Demerit
    Commented May 14 at 18:01
  • On a lot of the demo sites it doesn't. I went through all of the english languages ones listed here: civicrm.org/demo and some do and some don't. Like this one doesn't: demo.symbiotic.coop
    – zip
    Commented May 14 at 18:03
  • Oh ok 3rd party ones might have a different theme that doesn't show it. When you say custom fields, do you mean fields on CASES or on ACTIVITIES. I'm not sure CASE custom fields will appear on the print report?
    – Demerit
    Commented May 14 at 18:11
  • I think I see the problem. Give me a couple minutes.
    – Demerit
    Commented May 14 at 18:21

1 Answer 1

2

It seems something changed and is now case-sensitive. This fixes it for me: https://github.com/civicrm/civicrm-core/pull/30189

It's a one-letter change in CRM/Case/XMLProcessor/Report.php on line 962. Change

$extends = ['case'];

to

$extends = ['Case'];

1
  • Yup, that fixed the issue for me. Thanks!
    – zip
    Commented May 14 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.