1

Finally got a new install of Civi on what is a just installed Drupal 10 site.

When I got to Civicrm, I get a system error with this informations:

System Status: Error Public Assets Not Published Organization Setup Configure Default Mailbox Smarty Update (v2 => v4)

When I lick the link below to "Manage and see Details" it just says System Error with no Civi dashboard, just the default page from my website (which I have never had appear on a Civi install before).

I did look at the logs and got this:

2024-05-14 14:50:27-0700 [error] $Fatal Error Details = array:3 [ "message" => "DB Error: constraint violation" "code" => null "exception" => Civi\Core\Exception\DBQueryException {#2267 #message: "DB Error: constraint violation" #code: 0 #file: "/home/vsource4/www/www/edboost.org/vendor/civicrm/civicrm-core/CRM/Core/Error.php" #line: 974 #cause: DB_Error {#2263 +error_message_prefix: "" +mode: 16 +level: 1024 +code: -3 +message: "DB Error: constraint violation" +userinfo: "INSERT INTO civicrm_dashboard_contact (dashboard_id , contact_id , column_no , is_active ) VALUES ( 1 , 2 , 1 , 1 ) [nativecode=1452 ** Cannot add or update a child row: a foreign key constraint fails (vsource4_edboost2024_civicrm.civicrm_dashboard_contact, CONSTRAINT FK_civicrm_dashboard_contact_contact_id FOREIGN KEY (contact_id) REFERENCES civicrm_contact (id) ON DELETE CASCAD)]" +backtrace: array:46 [ 0 => array:6 [ "file" => "/home/vsource4/www/www/edboost.org/vendor/pear/db/DB.php" "line" => 986 "function" => "__construct" "class" => "PEAR_Error" "type" => "->" "args" => array:5 [ 0 => "DB Error: constraint violation" 1 => -3 2 => 16 3 => array:2 [ 0 => "CRM_Core_Error" 1 => "exceptionHandler" ] 4 => "INSERT INTO civicrm_dashboard_contact (dashboard_id , contact_id , column_no , is_active ) VALUES ( 1 , 2 , 1 , 1 ) [nativecode=1452 ** Cannot add or update a child row: a foreign key constraint fails (vsource4_edboost2024_civicrm.civicrm_dashboard_contact, CONSTRAINT FK_civicrm_dashboard_contact_contact_id FOREIGN KEY (contact_id) REFERENCES civicrm_contact (id) ON DELETE CASCAD)]" ] ] 1 => array:7 [ "file" => "/home/vsource4/www/www/edboost.org/vendor/pear/pear-core-minimal/src/PEAR.php" "line" => 575 "function" => "__construct" "class" => "DB_Error" "object" => DB_Error {#2263} "type" => "->" "args" => array:4 [ 0 => -3 1 => 16 2 => array:2 [ 0 => "CRM_Core_Error" 1 => "exceptionHandler" ] 3 => "INSERT INTO civicrm_dashboard_contact (dashboard_id , contact_id , column_no , is_active ) VALUES ( 1 , 2 , 1 , 1 ) [nativecode=1452 ** Cannot add or update a child row: a foreign key constraint fails (vsource4_edboost2024_civicrm.civicrm_dashboard_contact, CONSTRAINT FK_civicrm_dashboard_contact_contact_id FOREIGN KEY (contact_id) REFERENCES civicrm_contact (id) ON DELETE CASCAD)]" ] ] 2 => array:6 [ "file" => "/home/vsource4/www/www/edboost.org/vendor/pear/pear-core-minimal/src/PEAR.php" "line" => 223 "function" => "_raiseError" "class" => "PEAR" "type" => "::" "args" => array:8 [ 0 => DB_mysqli {#283 +_debug: false +_default_error_mode: null +_default_error_options: null +_default_error_handler: "" +_error_class: "DB_Error" +_expected_errors: [] +fetchmode: 1 +fetchmode_object_class: "stdClass" +was_connected: null +last_query: "INSERT INTO civicrm_dashboard_contact (dashboard_id , contact_id , column_no , is_active ) VALUES ( 1 , 2 , 1 , 1 ) " +options: array:8 [ "result_buffering" => 500 "persistent" => false "ssl" => false "debug" => 0 "seqname_format" => "%s_seq" "autofree" => false "portability" => 0 "optimize" => "performance" ] Someone with a similar problem on a Word Press site seems to have solved the problem by logging out and logging back in, but I tried that and also made a new admin Drupal user but same result.

Any thoughts? It took me a few tries to get this installed due to some other issues. Do I uninstall and try again?

** Update - I did a full uninstall including deleting the database. Did a reinstall on a fresh DB from the command line and I've checked the civicrm.settings.php to make sure all the paths are correct. Same issue.

Thanks for any help! -tiffani

2 Answers 2

1

After you installed Civi can you logout and login back into Civi?

2
  • I don't think I'm ever logging into Civi. When I click the Civi link, I just get the front page content from Drupal and this note: "Access Keys: System Status Powered by CiviCRM 5.73.1, free and open source AGPLv3 software." I don't see anything that looks like a Civicrm dashboard. May 15 at 20:54
  • Yeah, I meant logout and login back May 16 at 8:05
0

Civi home screen

Not really an answer but an update. Did a full uninstall and reinstall. According to my Drupal status page all systems are go.

However, I still get this screen when I got to the Civi home screen. When I click the Status link, the page is almost identical.

It doesn't look like Civi nor is there any way for me to log in or try to set anything up.

Am I missing something obvious here?

Thank you! -tiffani

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.