2

I installed CiviCRM 4.4 (LTS) on foo.example.com and then needed to move it to bar.example.com. I have updated the Resource URLs page with the new domain. However certain links, for example the links to "View and edit custom fields" on the custom data page at /civicrm/admin/custom/group still all point to the old domain.

I've tried drush cc all; drush -u 1 civicrm-update-cfg but the links are still the old ones.

Have I missed something? Thanks.

  • Maybe worth a try with Administer > System Settings > Cleanup Caches and Update Paths? – Laryn - CEDC.org Aug 20 '15 at 19:16
  • Thanks, tried that also but no good. – artfulrobot Aug 20 '15 at 20:21
4

I would double check the civicrm.settings.php file to make sure the paths and URL are updated in there. For example:

define( 'CIVICRM_UF_BASEURL'      , 'http://foo.example.com/' );

While you are in there make sure the server paths look right:

$civicrm_root = '/home/path_to_html/sites/all/modules/civicrm';
define( 'CIVICRM_TEMPLATE_COMPILEDIR', '/home/path_to_html/sites/default/files/civicrm/templates_c/' );
  • who-hoo! thanks, that was it! Knew I'd have missed something. Many thanks for your time. – artfulrobot Aug 20 '15 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.