1

On CiviCRM 4.6.7 on Drupal 7, under the report settings, there is an option to add the report results to a group. There is no button present for submitting it.

Upon reviewing the code I see this line

 <input style="display: none;"
 name="_qf_ContributionDetail_submit_group" value="" type="submit"
 id="_qf_ContributionDetail_submit_group" class="crm-form-submit">

The css has an element style of display: none;

I have overwritten this in my custom CSS style to make it display:block with a width, but the button has no text.

What's going on?

  • Hi - can you add a link to a Report on Demo site where this is occuring. Thx – petednz - fuzion Aug 24 '15 at 20:42
2

The submit button is hidden because the user does not need to click it. When selecting a group you will be instantly presented with a confirm dialog:

enter image description here

If this is not working for you, you might be experienceing javascript errors on your website. Try this troubleshooting guide.

  • I followed the troubleshooting guide - this was the offending extension. I disabled it, but an upgrade was also available. Note: this extension was also messing up the new tabbed layout of the report interface. CiviVolunteer (org.civicrm.volunteer) 4.5-1.3.2 – Zachary Aug 25 '15 at 18:58
  • If upgrading doesn't solve the problem, you can submit a bug report at issues.civicrm.org – Coleman Aug 25 '15 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.