3

Currently trying to set up PayPal Pro as a Payment Processor in Civi 4.6.7, following the instructions here:

http://wiki.civicrm.org/confluence/display/CRMDOC/PayPal+Website+Payments+Pro+and+Express+Configuration

Am I right in thinking that this requires the PayPal Classic API instead of the PayPal REST API? The instructions seem to differ quite a lot from what is presented on PayPal Dev.

Thanks

1

Hopefully someone else more knowledgeable chimes in, but in short: yes. The PayPal payment processor uses the older PayPal APIs. My understanding is that the new APIs are actually the PayFlow APIs, and thus are compatible with the PayFlow processor plugin. Each time this has come up for me, we were able to get the older API from PayPal, but you need to speak on the phone to a person.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.