We just underwent a migration from one server to another. For some reason, I don't have the same options to include Profiles I have previously created when I "manage" a contribution page I am configuring. The ebook says "select a CiviCRM profile from the dropdown menu..."

But when I try to do that, there are no real options. The "Include Profile (top of page)" is greyed out and the "Include Profile (bottom of page)" has a blank white text box but no options to select previously created profile or make new ones on the fly. Yes I have the profiles "activated" in the system but they still don't show up. What do I do?

  • Can you include version and screenshot? Aug 28 '15 at 12:00
  • What's changed with your set-up? From your post it sounds like this used to work but doesn't now. Perhaps an update that hasn't been successful? I've never come across this before, and it certainly doesn't sound like intentional behaviour.
    – Graham
    Aug 28 '15 at 13:40
  • Version 4.6.6. We just underwent a migration from one server to another. However that was done professionally and the hosting company says it's nothing they have seen before. I'm not sure how to post a screenshot.
    – JDM
    Aug 28 '15 at 14:30
  • I just do NOT get this page: book.civicrm.org/user/current/static/membership-profiles.png
    – JDM
    Aug 28 '15 at 14:50
  • are there any other pages you are 'not getting'? or is everything else working fine? have you turned on debugging?
    – petednz - fuzion
    Aug 28 '15 at 19:22

Try going to the include profile section and hit 'save', see if the profiles become available. I had a similar issue, and that fixed it.

  • Thank you but unfortunately it did not. It said "custom information has been saved" and nothing changed.
    – JDM
    Aug 27 '15 at 4:06

This might be a client-side JavaScript error. Enable Firebug in Firefox and browse to that form to see if errors are reported.


Since this happened after a migration, I'd recommend checking your base path in Admin > System Settings > Cleanup Caches and Update Paths (civicrm/admin/setting/updateConfigBackend?reset=1), saving if needed, and then hitting the "Cleanup Caches" button on that page.

cleanup caches button.

That might do it. If not, you could try the answer on this question related to civicrm.settings.php.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.