2

When I try to submit an HTML link in a custom field of the type Memo/Rich Text Editor, in some cases I get the error message:

There is a validation error with your HTML input. Your activity is a bit suspicious, hence aborting

The input is a hyperlink in the most simple form:

<a href="https://www.example.com">Link text</a>

What's especially strange is that there are more fields of the same type in the same form that accept exactly the same HTML syntax.

I found no difference between using TinyMCE and CKEditor.

CiviCRM version is 4.4.19.

Any clues highly welcomed.

4

The error you're getting is from the IDS (Intrusion Detection System). CiviCRM has a third-party IDS package that's bolted on, and it can certainly be overzealous. Its purpose is to prevent people from, e.g., submitting spam URLs into public forms.

However, assuming that you're logged in as an authenticated user and having this problem, the easiest solution is to grant yourself the "CiviCRM: skip IDS check" permission. You haven't specified your CMS, so I can't tell you where your permissions are, but grant your role that permission and you should see the error disappear.

  • The detection system seems to be very strict: I just linked some text with a previously uploaded file from the same server. Don't know why this should be "harmful". – Philipp Michael May 20 '16 at 11:29
  • This answer helped fix a problem for me too! – Andy Clark Jan 7 '17 at 8:39
  • Jon, my CMS is drupal, i tried setting that permission but still having same problem – Hassan Farooq Nov 1 '18 at 16:18
  • 1
    fyi - encountered this same error with Mosaico 1.1. The Skip IDS permission fixed it. – Dave T Mar 1 at 3:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.