1

With debugging and back tracing turned on, I receive the following error on our Drupal 7.38 and CiviCRM 4.6.8 site when trying to install the CiviCRM Strip 1.9.1 extension:

Exception: "API error: DB Error: constraint violation"

#0 …civicrm/CRM/Core/ManagedEntities.php(265): CRM_Core_ManagedEntities->onApiError("Dashboard", "create", (Array:6), (Array:4))
#1 …civicrm/CRM/Core/ManagedEntities.php(168): CRM_Core_ManagedEntities->updateExistingEntity(Object(CRM_Core_DAO_Managed), (Array:4))
#2 …civicrm/CRM/Core/ManagedEntities.php(141): CRM_Core_ManagedEntities->reconcileEnabledModule(Object(CRM_Core_Module), (Array:3))
#3 …civicrm/CRM/Core/ManagedEntities.php(122): CRM_Core_ManagedEntities->reconcileEnabledModules()
#4 …civicrm/CRM/Core/Invoke.php(403): CRM_Core_ManagedEntities->reconcile()
#5 …civicrm/CRM/Extension/Manager.php(246): CRM_Core_Invoke::rebuildMenuAndCaches(TRUE)
#6 …civicrm/CRM/Admin/Form/Extensions.php(195): CRM_Extension_Manager->install((Array:1))
#7 …civicrm/CRM/Core/Form.php(345): CRM_Admin_Form_Extensions->postProcess()
#8 …civicrm/CRM/Core/StateMachine.php(164): CRM_Core_Form->mainProcess()
#9 …civicrm/CRM/Core/QuickForm/Action/Next.php(61): CRM_Core_StateMachine->perform(Object(CRM_Admin_Form_Extensions), "next", "Next")
#10 …civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Next->perform(Object(CRM_Admin_Form_Extensions), "next")
#11 …civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Admin_Form_Extensions), "next")
#12 …civicrm/CRM/Core/Controller.php(353): HTML_QuickForm_Page->handle("next")
#13 …civicrm/CRM/Core/Page/Basic.php(395): CRM_Core_Controller->run()
#14 …civicrm/CRM/Core/Page/Basic.php(174): CRM_Core_Page_Basic->edit(1, NULL)
#15 …civicrm/CRM/Admin/Page/Extensions.php(125): CRM_Core_Page_Basic->run()
#16 …civicrm/CRM/Core/Invoke.php(312): CRM_Admin_Page_Extensions->run((Array:3), NULL)
#17 …civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:13))
#18 …civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#19 …civicrm/drupal/civicrm.module(489): CRM_Core_Invoke::invoke((Array:3))
#20 [internal function](): civicrm_invoke("admin", "extensions")
#21 /home/oursitename/www/www/includes/menu.inc(519): call_user_func_array("civicrm_invoke", (Array:2))
#22 /home/oursitename/www/www/index.php(21): menu_execute_active_handler()
#23 {main}

On the extension page, it appears as if the CiviCRM Strip extension has installed, but Stripe is not available as a payment processor.

Is anyone able to give guidance on next steps to troubleshoot?

1

I fixed this particular problem. I haven't been able to recreate the problem so I can't state the source, but the following steps allowed me to install the extension.

1) remove all other extensions from the extensions folder (including ones which were not installed). 2) truncating the civicrm_extension table 3) truncating the civicrm cache tables

Note that just trying v1.92 of the extension was not effective, nor was deleting the Stripe extension record in the civicrm_extension table.

0

My understanding is that you should use the 4.6.dev branch for CiviCRM 4.6. The README does state there will be releases/tags for each version...

There will no longer be branches for each version. The branches will be:

Civi's major.minor-dev, and we will create releases (tags) for each new release version.

Example: 4.6-dev.

...but the only release showing is 1.9.1 and there has been a lot of change (21 commits) since that was released in January. I'd recommend trying 4.6.dev and seeing if that solves this issue.

  • Thank you. I tried to install the 4.6 dev branch with the same results. I was able to install this extension on another site – so it must be something about this site's particular database … just can't figure out from the error message where to start looking. IOW, in plain language, to where is the error message pointing me? – Justin Young Sep 2 '15 at 22:42
  • Another data point: when I tried to enable a Drupal module, I get the following error now: "Exception: API error: DB Error: constraint violation in CRM_Core_ManagedEntities->onApiError() (line 453 of /home/mysitename/www/www/sites/all/modules/civicrm/CRM/Core/ManagedEntities.php)." – Justin Young Sep 2 '15 at 22:47
  • Do you have any other Civi extensions enabled? Maybe try disabling one by one if so. – Laryn - CEDC.org Sep 3 '15 at 1:52
  • Thank you. Yes, I have other extensions, but when I disabled one of the other extensions, I get the same error as above. – Justin Young Sep 3 '15 at 12:27
  • If this is a dev server, perhaps try deleting the extensions code base one by one? – Laryn - CEDC.org Sep 4 '15 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.