I am attempting to enable extensions on civiCRM 4.6.8 via WordPress 4.3.

When I go to administer - system settings - manage extensions I am told I need to set my Extensions Directory. I do so via my file manager at public_html/iowafarmersunion/wp-content/plugins/files/civicrm/custom_ext, paste this file location into Civi, but them an told that the CiviCRM extension directory does not exist.

Am I skipping a step? I was following directly on this page: http://wiki.civicrm.org/confluence/display/CRMDOC/Extensions#Extensions-WordPress

Thank you!

edit: I have made sure the directory's permissions are set to 777 for the time being and still no dice.

  • Did you leave off the opening slash? You've left it off in the question above. Sep 6, 2015 at 1:43
  • I did at first... whoops! Just added it and am still having the same problem.
    – ahnakay
    Sep 7, 2015 at 15:04

1 Answer 1


You need an absolute path from the server's root (/), and I doubt that there's a directory /public_html in your setup. More common situations are:

  • /var/www/public_html
  • /srv/www/yoursite/public_html
  • /home/someuser/public_html

or something similar.

You can tell by looking in your civicrm.settings.php file that's in wp-content/plugins/civicrm and scrolling down to the file paths. One of them will be to the templates_c folder, which should normally be in wp-content/plugins/files/civicrm. That path will be all the way to the root of your server, so you can just copy that and replace templates_c with custom_ext.

Of course, you could also look at the Temporary Files and Custom Files fields in your Directories admin page. Under normal circumstances, those should also be pointing to sibling folders of your custom_ext folder.

While you're at it, make sure you set the Extension Resource URL under Administer - System Settings - Resource URLs. You can probably use the Image Upload URL as an example, replacing persist/contribute with custom_ext.

Now, why CiviCRM doesn't just create the extensions folder and record its location when installing is totally beyond me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.