1

I created a smart group and want to display its result in a public page, ie visible even to a non logged in user. I followed the steps here: Public listings but still receiving:

The requested Profile (gid=17) is disabled OR
it is not configured to be used for 'Profile' listings in its Settings 
OR there is no Profile with that ID 
OR you do not have permission to access this profile.
Please contact the site administrator if you need assistance.

How can I display the results of a smart group on a public page?

I am using Civicrm 4.6.2

  • Andrea - you may want to spell out the precise steps you have done eg the settings on a field, the settings on the profile, your permissions etc. In terms of your version, you might want to check re security updates – petednz - fuzion Sep 7 '15 at 4:20
  • Hi @petednz-fuzion I got a bit confused and perhaps don't have a clear set of steps I took. What would be the correct process for setting a profile view to public? – andrea-f Sep 7 '15 at 10:39
  • have a look at andrei's answer below – petednz - fuzion Sep 7 '15 at 19:57
3

I will assist Xavier answer, as I don't have reputation to comment.

The user permission can be found navigating to Administer>User and Permissions>Permissions>WordPress Access Control URL: www.yoursite.com/wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/access/wp-permissions&reset=1

CiviCRM: profile listings and forms has to checked for anonymous user, if you have custom data in your profile, as Xavier says you will need to enable it as well.

Also make sure the profile has both "Standalone form or directory" and "Search view" checked.

And last, make sure your Smart group has "Public pages" as visibility, in the group settings.

Groups URL: www.yoursite.com/wp-admin/admin.php?page=CiviCRM&q=civicrm/group&reset=1

Hope that helps.

1

so does it work for authenticated users? that would exclude a bunch of potential errors.

What is your CMS? you probably need to add to anonymous users the right to see profiles, it might be disabled on your site.

Another common permission issue is to have custom fields on the profile, you'll need to add the permission to anonymous users to see custom fields

X+

  • Hi @Xavier yes it does work for authenticated users. I am using wordpress. Where do I add "anonymous users the right to see profiles"? And "add the permission to anonymous users to see custom fields"? Thanks – andrea-f Sep 7 '15 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.