1

I established a custom field (Anonymous) on the contribution object, which works well with the Contribution Detail report. I can use it to exclude anonymous contributions from that report, or to include only anonymous contributions. But when I try to use the field to exclude anonymous contributions from the Top Donors report, I get a DB error message: enter image description here

Background:

We just upgraded to CiviCRM 4.6.6 under Joomla! 3.4.3 (PHP Version 5.4.44 MySQL 5.6.23).

We enter contributions offline, some of which the donor wants to keep anonymous. I saw a Best Practices post on the CiviCRM community forum where Lobo recommended establishing a custom field on the contribution object for this, and have done so. I defined it as "searchable" so it shows up on the CiviReports Columns, Sorting, and Filters selection screens. But it seems trying to use it for any type of summary report (Contribution Summary, Top Donors, LYBUNT, etc.) results in the DB error message.

Is there some parameter within the Administrator that I can change to enable custom fields to be used as filters on summary reports? (The same error occurs if I try to use a different custom field defined on the contact object in a filter for a summary level report.) I don't know if this is specific to Joomla! installations. (I'm a newbie and not a techie.)

Thanks for any advice!

  • This happens on the demo server as well -- tested with Contribution Summary report (worked) and Top Donors report (didn't work). – Laryn - CEDC.org Sep 9 '15 at 16:40
  • The behavior you're expecting is the correct behavior. You're seeing a bug. If you can replicate it on the demo server with Debugging and Backtrace turned on, you can probably submit a bug report for it. That said - the core team with their limited resources may not fix this on their own just because you submit it. You may want to hire someone to patch it and send them the patch - or to submit it to the paid issue queue: civicrm.org/paid-issue-queue – Jon G - Megaphone Tech Sep 11 '15 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.