3

OK, this is a new one to me. I'm running CiviCRM 4.6.6 on WordPress 4.3. For the individual contacts I added manually, CiviMail works awesome. But here's where things get weird.

I just finished importing a list of contacts into a new group (not a big list, just 104, that were exported from a previous CiviCRM install). I made sure to select only basic fields to import. Imported them into a new group. Import seemed to go fine. Changed the group setting to Mailing List.

But then when I tried to use CiviMail to send a mail to that group, CiviMail says "No Recipients."

So I added an previously entered contact into the new group, and when I tried CiviMail again, it says "1 recipient" (even though there are 101 showing up in the group).

What gives?

2

When you look at Groups tab for one of the imported contacts, is the status of the Group "Added"? My suspicion is that the status is "Pending" and thus it will be excluded from use.

Pending is used by CiviCRM to allow permission by end users to use the email address and is used when the Group is set as "Public Pages".

You should make sure the group is set as "User and User Admin Only" which should remove the permissioning component. (I think you need to reimport the contacts, or at least re-add them to the group once the setting is fixed.)

More on this can be found in the Visibility section here: http://book.civicrm.org/user/current/organising-your-data/groups-and-tags/

1

This looks like it may be related: When sending mailing incorrect amount of contacts displayed

In short, for CiviCRM 4.6 and earlier, imports may set the "Is Deceased" value to NULL instead of explicitly setting it to 0. These people are excluded from mailings so you need to set that field correctly. (e.g. UPDATE civicrm_contact SET is_deceased = '0' WHERE is_deceased IS NULL;)

This was fixed in 4.7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.