1

I get the following Warnings when export contacts after performing an advanced search:

Blockquote Warning: strpos(): Empty needle in /home/iskcohdx/public_html/crm/wp-content/plugins/civicrm/civicrm/CRM/Export/BAO/Export.php on line 600

Blockquote Warning: Cannot modify header information - headers already sent by (output started at /home/iskcohdx/public_html/crm/wp-content/plugins/civicrm/civicrm/CRM/Export/BAO/Export.php:600) in /home/iskcohdx/public_html/crm/wp-content/plugins/civicrm/civicrm/CRM/Utils/System.php on line 833

What could be the cause of this and how to fix this issue? I'm using CiviCRM 4.5.3 on Wordpress.

3

It's likely an issue with the code. The fastest "fix" is to hide that armless message by changing the setting. you add in your civicrm.setting.php that line:

ini_set("error_reporting", 0);

and it should avoid to show that message.

Beware that it means that you might have other errors (eg. from other modules) that will be hidden too.

  • I added the above line to the civicrm.setting.php file, but I still get the same result. The message still appears. Any other thoughts? – Sudesh Apr 20 '15 at 14:43
  • I changed the above line in the civicrm.settings.php file to the below line and now it works fine: ini_set("error_reporting", 0); – Sudesh Apr 23 '15 at 7:04
  • 1
    ok, changed the answer accordingly. Keep in mind you don't fix anything, just hide the warning ;) – Xavier Apr 24 '15 at 15:11
1

This looks like a bug. Can you try to replicate it on d45.demo.civicrm.org? Please create an issue for it at issues.civicrm.org indicating if you were able to replicate it on the demo site or not. As export errors can arise because of interactions involving the field mapping configuration and / or data, it might be useful to include a screen shot showing your specific field mapping when creating the issue.

  • Hi Joe. I have tried to replicate on d45.demo.civicrm.org, but cannot. It works fine on the demo site. I have just migrated our system to 4.6.2 this weekend.I get the same problem on 4.6.2. So it seems maybe, an issue specific to my installation. My Wordpress version is 4.1.1 – Sudesh Apr 20 '15 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.