2

I am using CiviCRM with Wordpress but I am having some trouble with getting pages in Civi to work in Wordpress.

For example, any time I try to view a contribution page, it takes me to a Wordpress page called CiviCRM that says "Do not delete this page. Page content is generated by CiviCRM."

No Civi content is actually there, just that text.

How can I get the actual contribute pages?

  • In addition to what Parvez has suggested, are you creating a page (or a post) and inserting the shortcode to the contribution page? The default page, typically civicrm is used internally to present the CiviCRM content. – Kevin Cristiano Sep 16 '15 at 0:21
  • Out of interest, what settings do you see in "Administer -> System Settings -> CMS Database Integration"? Sounds like your Base Page setting might be awry. – Christian Wach Sep 17 '15 at 10:51
  • I am also seeing the issue where CiviCRM is not paying attention to the WordPress site address (mysite.com) and is instead using the installation folder (https:mysite.com/wordpress). I have tried creating the dummy parent page (/wordpress) with CiviCRM 5.0.1 and it does not seem to work. I keep getting the "Do not delete this page. Page content is generated by CiviCRM." message rather than a rewritten page. The [civicrm component="user-dashboard" hijack="1"] shortcode produces a page, but it does not appear to be fully functional. I am using the Enfold (child) theme, and have turned al – user3692999 Apr 22 '18 at 22:03
2

I just create a page called 'Contribute' or something like that, then either use the shortcode button the CiviCRM supplies in the page/post editing interface as Kevin mentioned above. Or, depending on how you like to build your Wordpress site, use Wordpress's do_shortcode method straight in your page template

2

Well I figured it out... It turns out that I had forgotten to activate the shortcode in the CiviCRM Admin Utilities plugin. It was that simple... once I checkmarked the shortcode for posts and pages, I was able to manually add the contribution pages to WP pages.

I do still have a CiviCRM page that says "Do not delete this page. Page content is generated by CiviCRM." and CiviContribute still does link directly to that page for some reason... but I am able to use the shortcode now so it's not a problem.

  • Interesting feedback. I'll update CiviCRM Admin Utilities so that it enables shortcodes on all post types by default. – Christian Wach Sep 18 '15 at 13:37
  • 1
    As per my comment above, what settings do you see in "Administer -> System Settings -> CMS Database Integration"? Sounds like your Base Page setting might be awry. – Christian Wach Sep 18 '15 at 13:37
  • The CMS Integration settings look correct to me... it tells me the users table is "users" and it has my Wordpress base page listed as "[mysite]/wordpress/civicrm" – osarusan Sep 20 '15 at 0:00
  • 1
    It would be great if you could dig into this and post your answer below - for those of us who might encounter this issue in the future :-) – Christian Wach Sep 23 '15 at 16:07
  • 1
    Well, I am positive that it has to do with the fact that I have Wordpress installed in its own subdirectory but still run it from the siteroot. CiviCRM and Wordpress's Pretty URLs don't seem to work all that well with each other. WP kept rewriting the Civi-generated urls from /wordpress/civicrm to /civicrm and causing the civi-generated content not to appear. However, making dummy content (pages) with the correct URL structure (a parent page called wordpress and a child page called civicrm) forced WP to stop rewriting that URL (since it now exists in the database) and solved the problem. – osarusan Sep 24 '15 at 16:29
1

I'd try the site using the default theme, we've seen issues in the past where custom themes were causing problems.

0

I had the same situation installing CiviCRM 4.7.25 on my testing server. WordPress is installed in a subfolder (wp), but the WordPress 'Site address' is just the website's domain.

Osarusan's last solution fixed the problem - I added a dummy page named with a url like mysite.com/wp and made the CiviCRM page a child page of the wp page.

It seems that CiviCRM is using the WordPress installation folder as the base for the url of the CiviCRM page when it should probably be using the WordPress 'Site address' as the base.

  • Thanks for your post Don but this doesn't really answer the question. StackExchange isn't a forum and works best if you stick to the question and answer format. civicrm.stackexchange.com/help/how-to-answer – William Mortada Oct 8 '17 at 18:22
  • I wanted to emphasize that Osarusan's solution seems to work best for sites where WordPress is installed in a subfolder. I would have simply voted it up if I had been allowed to do so... – Don Alejandro Oct 9 '17 at 18:43
  • 1
    CiviCRM version 4.27 for WordPress corrects this problem so that it is no longer necessary to make the front-end CiviCRM page a child page of a dummy 'wp' page. If you've made the civicrm page a child of wp, you'll have to change it to 'no parent' when updating to 4.27. – Don Alejandro Nov 8 '17 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.