5

The requested URL /civicrm was not found on this server. CiviCRM 4.6.3 Wordpress 4.1.1

After having created a campaign widget the example.com/civicrm returns a 404 HTTP response, when clicking on "contribute"?

This instance of Wordpress is running on apache and virtualhosts with other Wordpress installations

Already tried whats here: Forum CiviCRM

Thanks keep up the great work!

  • > They should be Post Name (%postname%) That setting is here: example.com/wp-admin/options-permalink.php Is there a way to use another permalink structure, like /%category%/%postname%/ ? – Ottó Radics Nov 2 '17 at 10:59
6

Can we verify a few things?

What are your WordPress permalinks set to?

They should be Post Name (%postname%) That setting is here: example.com/wp-admin/options-permalink.php

This will add to your .htaccess file the following:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Now can you go to example.com/wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/setting/uf&reset=1

This is the menu option Adminsiter -> System Settings -> CMS Database Integration.

You should see 'civicrm' in the WordPress Base Page setting. If not, add it there.

Confirm that there is a WordPress page titled 'CiviCRM' in the list of WordPress Pages: example.com/wp-admin/edit.php?post_type=page

This page should have a permalink of example.com/civicrm

Once all these settings are in place, you should be good.

  • Nice answer, Kevin :) – michaelmcandrew Jun 2 '15 at 21:45
  • Thank you for this. The one thing I hadn't done is change the Permalinks setting from "Default" to "Post name" which fixed everything. This really should be in the documentation somewhere or perhaps I missed it. – Pancharatna dasa Jul 3 '15 at 16:18
0

I ran into this problem because my CiviCRM site is located at url www.blah.com/ and not at www.blah.com/civicrm. I fixed it by clearing the WordPress Base Page setting box (see Kevin's post on how to set the WordPress Base Page)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.