0

Using default contribution receipt message template, the receipt email shows "array" rather than custom field values. It works correctly if no custom fields are used in profile.

This seems like this issue which does not seem to be closed. https://forum.civicrm.org/index.php?topic=27587.0

Using Civi 4.6.8 enter image description here

  • I just tested this out and custom_fields used for Contribution are properly retrieved in the mail. Can you provide some more details, screenshot, etc ? eg. Type of the custom_field ? – jitendra - fuzion Sep 24 '15 at 9:38
  • I have done more testing and the problem is not consistent. Where might I look for error details that would better indicate the cause of the problem? Thanks for help. – Dave T Sep 24 '15 at 11:03
  • More testing - seems to work OK if I am logged in (as admin user) but not if I am completing form as an anonymous user (using Drupal). Profile permissions are checked for anonymous user. Are there other permissions that might be necessary to complete a membership contribution page with profile? – Dave T Sep 24 '15 at 11:56
  • I have checked and rechecked permissions including profile, contribute permissions. The form successfully creates new contacts with all of the profile information. Any different permissions that would affect the email receipt template behavior? – Dave T Sep 24 '15 at 12:28
  • Can you recreate this on our sandbox site d46.demo.civicrm.org. If yes, then it seem to be a bug in core:( – jitendra - fuzion Sep 24 '15 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.