2

When I save the Extension Resource URL it is rewritten from:

/var/www/vhosts/examplesite/httpdocs/wp-content/plugins/files/civicrm/custom_ext

to

https://www.examplesite.com//var/www/vhosts/examplesite/httpdocs/wp-content/plugins/files/civicrm/custom_ext

It looks like it is taking the https://www.examplesite/ part from the civicrm.settings.php file:

define( 'CIVICRM_UF_BASEURL'      , 'https://www.examplesite.com/' );

I'm getting a number of errors telling me that extensions are pointing to the wrong place, so I figure I've gone astray somewhere in the settings. I see the Extension Resource should be the same as the CiviCRM Extensions Directory, which currently is:

/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/files/civicrm/custom_ext

Where have I gone wrong? Any pointers much appreciated!

Edit:

So I changed the Resource URL to https://www.examplesite.com/wp-content/plugins/files/civicrm/custom_ext, but I still seem to get an error indicating that maybe the extensions are still not pointing to the right place?

mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required 'CRM/Core/Session.php' (include_path='/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/files/civicrm/custom_ext/uk.co.vedaconsulting.mailchimp-1.0-beta4/:/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/files/civicrm/custom_ext/com.drastikbydesign.stripe/packages/:/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/files/civicrm/custom_ext/com.drastikbydesign.stripe/:.:/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/civicrm/civicrm:/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/civicrm/civicrm/packages:/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/civicrm/civicrm/vendor/phpseclib/phpseclib/phpseclib:.:/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/civicrm/civicrm/:/var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/civicrm/civicrm//packages:.:') in /var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/files/civicrm/custom_ext/uk.co.vedaconsulting.mailchimp-1.0-beta4/mailchimp.php on line 442

7
  • 1
    Maybe the Extension Resource URL should just be an absolute URL, like: https://www.examplesite.com/wp-content/plugins/files/civicrm/custom_ext ? Sep 29, 2015 at 20:50
  • That's exactly the Extension Resource URL in your case. Have a look at DaveFF answer.
    – Andrei
    Sep 30, 2015 at 9:11
  • Maybe the URL in the CiviCRM Extensions Directory should be the full URL: https://www.examplesite.com/wp-content/plugins/files/civicrm/custom_ext rather than /var/www/vhosts/examplesite.com/httpdocs/wp-content/plugins/files/civicrm/custom_ext? Sep 30, 2015 at 16:21
  • Have another check through of all your entries in civicrm.settings.php
    – petednz - fuzion
    Sep 30, 2015 at 18:13
  • Extensions Resources URL: https://www.examplesite.com/wp-content/plugins/files/civicrm/custom_ext Extensions Directory Path: /var/www/vhosts/examplesite.com/httpdocs/wp-content/files/civicrm/custom_ext/ (don't forget the last slash "/"). CiviCRM Base URL: https://www.examplesite.com (note the "s" in https:// if you are using SSL) after that cleanup caches and update paths. Also after applying this changes, as @petednz suggests double check your entries in civicrm.settings.php if after that you're still facing the same issue you might need to provide more info about your server.
    – Andrei
    Oct 1, 2015 at 8:39

1 Answer 1

2

The 'Extension Resource URL' under 'Resource URLs' is the web-accessible URL that points to the extensions directory, not the path to that directory on the server's filesystem. The path on the server belongs in 'CiviCRM Extensions Directory' under 'Directories'.

Edit: for the example shown, the 'Extension Resource URL' is 'https://ffnew/sites/default/extensions' for a 'CiviCRM Extensions Directory' of '/var/www/html/prod/drupal/sites/default/extensions'. This will differ if you're not on Drupal.

Extensions URL

1
  • Thanks Dave, this all looks to be more or less what I have now, but I am still getting an error that seems to imdicating the the extensions are going to the wrong place. Sep 30, 2015 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.