3

We are seeing intermittent behavior with CiviCRM and Wordpress. Sometimes the membership registration page will create a new Wordpress account as expected. Sometimes it doesn't. What would cause this behavior?

The CiviCRM membership registration page has the Wordpress account creation required checked in the profile and primary e-mail is present on the form. Here is the form for reference: https://aslta.org/membership/selection/

WordPress 4.3.1 CiviCRM 4.6.6

3
  • intermittent behaviour is really hard to pin down. any common characteristics?
    – petednz - fuzion
    Oct 1 '15 at 21:47
  • are the users definitely entering a username and password on the registration page? Oct 2 '15 at 10:50
  • Yes, the username and password are required -- so they are entering it. What I'm seeing is that once in a while there will be a WordPress registration for a given CiviCRM membership registration. I haven't been able to see any common characteristics among them yet.
    – Bobby Cox
    Oct 5 '15 at 16:46
2

+1 for this question - I have had the same issue and I don't have the skills to pin it down. We have a "members only" section of our website and so having up-to-date WP Users is quite important. As a workaround, I go in about once a month and export "current" members from CiviCRM and then import them into WordPress to ensure that there are WP User accounts for each. It's messy but...

I thought it was just a bug with how we've got CiviCRM/WordPress setup (we're amateurs and muddling our way through!).

(Sorry this isn't a comment - I don't have enough cred yet to post them :). But it's an answer, just not a good one!)

1
  • Yeah! Glad to hear that we're not the only ones seeing this. I'll probably start looking into filing a bug with the CiviCRM team.
    – Bobby Cox
    Oct 8 '15 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.