We're running CiviCRM 4.6.8 on WordPress 4.3.1.

I've been getting the following error message since the last CiviCRM upgrade:

Warning Your database is configured to use the MyISAM database engine. CiviCRM requires InnoDB. You will need to convert any MyISAM tables in your database to InnoDB. Using MyISAM tables will result in data integrity issues.

The site is on a shared server, so I can't change the storage engine unless we move the website to a VPS package.

Does it matter? Should we fork out the $ for a VPS? Migrate elsewhere?

3 Answers 3


You can find a number of shared hosts that do support InnoDB if your budget doesn't cover costs for a VPS (not to mention that you may/not have the expertise or time to manage/administer a virtual private server).


To speak to the worth of a VPS -- yes, it is worth the money to use a VPS instead of shared hosting when CiviCRM is involved. Certainly, you get the benefit of controlling your server environment for things like database engine changes, but perhaps the biggest benefit you will see is increased performance. The shared environment may work in the short term, but as your database and needs grow, I suspect you will hit limitations with your hosting.

See this question for reference: Choosing a VPS solution for CiviCRM

  • 1
    It's true we've hit the limit now and again but, generally, shared hosting fits our needs :) We're only a small association. I think changing providers is the right answer here!
    – Esther
    Oct 7, 2015 at 2:11

And you can not use MyISAM for CiviCRM!

  • It's been working for the past 2 years, it'll be interesting to see what difference it makes! :) It's only since the last upgrade that we've been receiving the error message. So maybe it's not the upgrade itself causing the error, but that the message is now built-in!
    – Esther
    Oct 7, 2015 at 2:12
  • There are some triggers on tables, as far as I know they cause errors when you are using MyISAM. Also, in the installation instructions on the CiviCRM documentation wiki there is this message: MySQL 5.1.x or higher with INNODB support : CiviCRM is compatible with the current generally available MySQL release. Trigger permission is required. SUPER privileges are required in MySQL 5.1 if binary logging is enabled. See the CiviCRM MySQL Permission Requirements page. Oct 11, 2015 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.