3

I use a custom Drupal Webform for contacts to join groups. This happens within a restricted environment, the user is logged in and managing his/her own profile behind a password. I don't want any e-mail to be sent.

When a group is marked as 'mailing list', CiviCRM sends out a confirmation mail. If a group is marked both 'mailing list' and 'access control', no e-mail is sent.

I've unchecked 'Enable Double Opt-in for Profile Group(s) field ' in the CiviMail component. Doesn't seem to make a difference (this is not a 'profile groups checkbox' as per the description there i think - its a webform).

So I'm about to check the 'access control' for a dozen of groups, only to disable the e-mail confirmation. What am I doing wrong ? :-)

  • According to this civicrm.stackexchange.com/questions/6818/… I could also uncheck the mailing list box in my case ... – commonpike Oct 4 '15 at 14:04
  • Unfortunately Andrew Hunt mentions there that that is a bug, not a feature – commonpike Nov 2 '15 at 12:57
  • .. and the bug has been fixed in 4.7.10, at least. so that's not an option anymore. – commonpike Sep 23 '16 at 8:40
1

You probably saw this but there is a second setting that deals with Double Opt-In - but since you only referred to one, the other one is

Enable Double Opt-in for Profiles which use the "Add to Group" setting When CiviMail is enabled and a profile uses the "Add to Group" setting, users who complete the profile form will receive a confirmation email. They must respond (opt-in) before they are added to the group.

Also at this path - civicrm/admin/setting/preferences/mailing?reset=1

  • Thanks, saw that. I'm not using a profile, I'm using a Drupal Webform. – commonpike Oct 5 '15 at 11:57
  • i think you should note that in the question, and add webform-civicrm tag - may help – petednz - fuzion Oct 6 '15 at 1:44
1

You may have been here / tested already, but I believe if you are in Drupal Webform, there is another 'confirm subscription' configuration under the 'Additional Options' tab which is checked by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.