1

Keep getting this error when Upgrading from 4.4.14 to 4.6.2 directly. I am upgrading based on the civicrm documentation.

Seems like civicm_mailing_abtest has some error. But I have checked I did not have this table in 4.4 version and it was created during the upgrade process.

How to deal with it?

enter image description here

DB Error: unknown error in unknown on line unknown nativecode=1060 ** Duplicate column name 'created_id' ALTER TABLE civicrm_mailing_abtest ADD COLUMN created_id int unsigned

  • Did you somehow try to run the upgrade multiple times? Do you have a backup of the original database? – Laryn - CEDC.org Apr 22 '15 at 16:21
  • Yes, I have backup of original civi db. I tried to installed on multiple instances from backup plus on a brand new install. It always fails! Upgrading from 4.4.14!! – Tapash Apr 22 '15 at 20:20
  • 1
    Tapash - can you confirm whether you used a MySQL 'DROP DATABASE cividatabasename' and 'CREATE DATABASE cividatabasename' between installs? – Jon G - Megaphone Tech Apr 24 '15 at 5:17
  • I tried upgrade by the civicrm book, nothing otherwise. – Tapash Apr 24 '15 at 20:35
  • just got exact same on site upgrading from 4.4.19. Same spot 4.6.alpha7 - i didn't set this running so not sure if sql backup had any special treatment. tapash do you recall anything more about getting past this? it is odd since we had done a test upgrade for them many many months ago and i don't see any record of hitting this that time – petednz - fuzion Mar 28 '17 at 4:44
2

That looks very strange error, it appears to be complaining that the created_id column is being created twice, However looking through the upgrade sql files on the github repo, I can only see the one reference to creating created_id column on that table and that is in the 4.6alpha7.sql file. I do note that it came from this JIRA case https://issues.civicrm.org/jira/browse/CRM-15970. Perhaps you should raise it as a bug in the Jira system but also would recommend looking through the upgrade sql files on your system to see if they match what is in the git repo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.