2

Set up profile, check. Set up relevant menu item as "CiviCRM" then "Profile Search", check. In the "Options" tab have selected the relevant profile.

So why is the page only displaying the placeholder text from the original K2 article?

1

This has kind of been stated before, but you need to make sure that what you are exposing to Joomla is viewable by all unless you are requiring people to log in first before they can see the content (such as with a members area). You may want to elaborate on what your end goal is, because a profile search may require higher permissions than a profile view. If you are looking for just a general directory listing, you may not need a search.

| improve this answer | |
  • Side note: while I still thing my original answer is more on point, it sounds like it might be possible that you don't have a plugin enabled. If your placeholder text is something like {name of something} in the curly braces, that is usually a sign that a plugin that would normally translate that into the desired content isn't active. Again, more information is needed to be able to help further. – Randy Tobias May 15 '17 at 19:30
0

Perhaps, because you did not set the correct ACL-setting for this page?

| improve this answer | |
  • 3
    The more thorough an answer can be, the more helpful it is for others. Please elaborate about the ACL settings you might suggest. – Andrew Hunt Oct 17 '15 at 0:53
0

Are you requiring user login to view menu item? Is ACL setup to view menu item contents, i.e. with civi or are you planning to do public search? I have done this especially for geographic search, works like a charm but there is a bit to do for ACL first. If you need help, ask away.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.